Not all spam recognized

Whether you're a MailWasher veteran or complete newbie, all users are welcome to get together. Discussions include usage and possible problems.
Kafka
Student Sheep
Posts: 19
Joined: Sat Jul 30, 2016 10:26 am

Not all spam recognized

Mon Jan 27, 2020 1:16 pm

I have had Mailwasher Free for several years. Of late I am finding that not all emails are shown as being either spam or legitimate (i.e. they are not highlighted in either red or green). Is this because Mailwasher Free will only look at a limited number of emails?
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 15092
Joined: Mon Jun 13, 2005 6:27 pm

Re: Not all spam recognized

Mon Jan 27, 2020 1:18 pm

Hi there

No, there's no limit like that. First thing I would check is under Settings >> General >> Checking Mail >> have the Spam Throttle set to at least 200 lines per email, that should give MailWasher enough data to work with.

Failing that, it couldn't hurt to get some logs, in case there is something odd going on.
To do that go Help >> Send Support Logs >> enter a brief description like 'learning not working well' >> in the Ticket Number field enter chris >> Send Logs >> reply back here once sent, so I can check the logs arrived all OK.


Thanks
Kafka
Student Sheep
Posts: 19
Joined: Sat Jul 30, 2016 10:26 am

Re: Not all spam recognized

Mon Jan 27, 2020 1:24 pm

Thanks,

I have set the throttle to 320. Hopefully this will do the trick.

Regards,
Michael
Kafka
Student Sheep
Posts: 19
Joined: Sat Jul 30, 2016 10:26 am

Re: Not all spam recognized

Wed Jan 29, 2020 12:55 pm

Thanks Chris,

Setting the Spam Throttle to 320 didn't have any apparent effect. I have forwarded you the Support Logs (though I wasn't told whether they had been sent).

Regards, Michael
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 15092
Joined: Mon Jun 13, 2005 6:27 pm

Re: Not all spam recognized

Wed Jan 29, 2020 1:57 pm

I can't see anything obvious, so this is a touch puzzling. But I can see MailWasher making some detections, and it is adding emails to the learning, so nothing serious at least.

The storage of your good/spam probabilities do look light, which might be the reason. As a small comparison, my MailWasher has 4x the information and I fully reset mine back in September.

Have you manually hit the Reset Learning option under Settings >> Spam Tools >> Learning Settings ?

Do you perhaps run AVG TuneUp or any other kind of cleanup software ?

Presumably too there's been no reset of MailWasher, or manual deletion of it's cache files that you know of ?
Kafka
Student Sheep
Posts: 19
Joined: Sat Jul 30, 2016 10:26 am

Re: Not all spam recognized

Wed Jan 29, 2020 6:17 pm

I haven't hit the Reset Learning Option. Whilst I don't use AVG TuneUp I do use CCleaner and Glary Utilities. I haven't reset Mailwasher or deleted its cache files (not intentionally anyway). I did have an app called Click'nClean or similar but I rarely used it and have now deleted it.
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 15092
Joined: Mon Jun 13, 2005 6:27 pm

Re: Not all spam recognized

Wed Jan 29, 2020 6:35 pm

I can see Glary does look for MailWasher files, but from what I can tell it's just looking for log files. CCleaner also had a bug a long time ago where it wiped necessary MailWasher files, so just be sure both programs are up to date.

From Glary main screen >> go into 1 Click Maintenance >> click Options >> on the left select Temporary Files Cleaner >> in the list on the right check for an entry for MailWasher >> if present uncheck this >> click OK.

Also in MailWasher under Help >> User Files >> open the cache folder >> right click on the column heading and select to show the Date Created column >> check the date created for the .dat files, say mwp_pmap.dat

What's the creation date of that file, and also MWP.db3


Thanks
Kafka
Student Sheep
Posts: 19
Joined: Sat Jul 30, 2016 10:26 am

Re: Not all spam recognized

Wed Jan 29, 2020 8:03 pm

Glary didn't have Mailwasher checked. All the DAT files were dated 29/01.2020 except mwp-inw.dat, mwp_conv.dat and mwp_exw.dat which were dated 02/11/2016.
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 15092
Joined: Mon Jun 13, 2005 6:27 pm

Re: Not all spam recognized

Wed Jan 29, 2020 8:24 pm

Kafka wrote:
Wed Jan 29, 2020 8:03 pm
Glary didn't have Mailwasher checked. All the DAT files were dated 29/01.2020 except mwp-inw.dat, mwp_conv.dat and mwp_exw.dat which were dated 02/11/2016.
Was that definitely 'Date Created' and not 'Date Modified' ?
If it was created, then that could mean whatever is wiping/cleaning up these files is still going on.

In Glary go into 1 Click Maintenance >> click Options >> on the left select Log down the bottom >> it should present you with a list of log files. If you want to just send them to me to check feel free, email address is forum@firetrust.com

I'm not actually sure how it stores the logs, by date or by program etc...
Hopefully it's obvious which log files are recent.



I would also recommend avoiding your cleanup programs for a few days, just while you are spending time on this.
Kafka
Student Sheep
Posts: 19
Joined: Sat Jul 30, 2016 10:26 am

Re: Not all spam recognized

Mon Feb 03, 2020 10:11 am

Did you receive my log files? The problem is still there. This morning I had a large number of unrelated emails, all of which were spam.
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 15092
Joined: Mon Jun 13, 2005 6:27 pm

Re: Not all spam recognized

Mon Feb 03, 2020 10:37 am

Kafka wrote:
Mon Feb 03, 2020 10:11 am
Did you receive my log files? The problem is still there. This morning I had a large number of unrelated emails, all of which were spam.
I got the MailWasher logs you sent on the 29th. They were showing no errors or other odd activity, just that MailWasher was working and your Learning data was quite light, as though it had been recently reset or files removed.

Has the creation date of those files I mentioned earlier been reset again ?

Return to “Troubleshooting and Help for MailWasher 5 and 6”