Access violation

Whether you're a MailWasher veteran or complete newbie, all users are welcome to get together. Discussions include usage and possible problems.
rronne
Mystified Moa
Posts: 5
Joined: Wed Feb 03, 2010 5:25 pm

Re: Access violation

Tue Mar 23, 2010 4:03 am

The more I thought about this problem and the problems I have been having for a couple of years I now think that the access violations that I was getting is an interaction between Mailwasher Pro and RealVNC. I use RealVNC to remotely control the computer that is running MailWasher Pro. Last night I sent Nick the session log.txt file and he acknowledged getting it. He was forwarding it on to support.

This morning I un-installed the RealVNC and will see if that seems to solve the problem.

It would be interesting to know if any of the rest of you that are getting Access Violation at Address 0045AC9C in Module Mailwasher.exe Read Address of 000000000004 - Are you running RealVNC.

Because this is a virtual machine by virtualbox ver. 3.1.4 running Win XP sp3 and I was running no other software not even antivirus the only other program running is the virtualbox guest additions. Also I ran This virtual PC box for quite awhile without RealVNC and no access violation errors, then it was not long after installing RealVNC I started getting the errors. I can often get the error anytime there are emails in my list (if I hide my friends emails) then I can not produce the error. Only when there are emails in the list - then all I have to do is move the mouse over the area of the list and the error will often pop up.
rronne
Mystified Moa
Posts: 5
Joined: Wed Feb 03, 2010 5:25 pm

Re: Access violation

Tue Mar 23, 2010 3:29 pm

After removing RealVNC my MailWasher ran all day without any access violations. I do now feel fairly confident that the problem of my Access violation errors was cause by the interaction between these two programs.

I will update my post if I get any more errors, but for the time being my work around is to remove RealVNC
adrianus
Mystified Moa
Posts: 7
Joined: Wed Nov 25, 2009 12:30 am

Re: Access violation

Tue Mar 23, 2010 3:59 pm

I'm not using RealVNC, but still get the problem as reported (I'm using Vista-64 on a Dell XPS13) - so it's unlikely that RealVNC is the root cause. I've also provided logs to Nick ...
User avatar
stan_qaz
Omniscient Kiwi
Location: Gilbert, Arizona
Posts: 8671
Joined: Fri Jul 25, 2008 5:13 am

Re: Access violation

Tue Mar 23, 2010 5:28 pm

I've been running MW for years using TightVNC which I like a bit better than any other version I've tried. Never had an issue with it.

http://www.tightvnc.com/download.php

Do go to the bottom of the page and grab the mirror driver too, lower CPU load and faster screen updates.
I am not a Firetrust employee just a MW user.
--
First rule of computer consulting: Sell a customer a Linux computer and you'll eat for a day,
sell a customer a Windows computer and you'll eat for a lifetime.
rronne
Mystified Moa
Posts: 5
Joined: Wed Feb 03, 2010 5:25 pm

Re: Access violation

Wed Mar 24, 2010 3:07 pm

My Virtual machine ran for more than a day without any access violations so I re-installed RealVNC and within minutes I got the access violation when VNCing into my virtual WinXP PC. So at least for my case it does appear to be related to one or the other of the programs interacting with the other. Even though I have had this problem on two seperate computer on a third computer running lots of extra programs and stuff my wife has never had a problem with access violations, yet she is running Mailwasher 6.3
and RealVNC 4.5.1 and yet no problems.

But at least for me the problem seems to be solved by removing RealVNC.
drkdesyre
Rattled Rabbit
Posts: 3
Joined: Thu Aug 01, 2013 8:21 am

Re: Access violation

Thu Aug 01, 2013 8:29 am

I never saw a resolution to this access violation problem but have found that if you disable "Learning", it will stop the issue.
dl3mcj
It begins with a single step
Posts: 1
Joined: Sat Dec 20, 2014 3:23 am

Re: Access violation / solution?

Sat Dec 20, 2014 3:44 am

I got the following problem(s) with my MaiWasher 4.1 on an Windows XP system:
  • MailWasher symbol doesn't blink when a new mail arrives
  • The sound isn't played when a new mail arrives
  • The file "spamLog.txt" shows an error message like "Exception 508 8:49:56.187: occurred during Training thread - 10b: Access violation at address 00580893 in module 'MailWasher.exe'. Read of address 00000014 (EAccessViolation)" zeigte einen Fehler in der Datei "Training archive - legitimate.rot135"
I solved this problem on my system this way:
  • close MailWasher
  • got to C:\Dokumente und Einstellungen\<username>\Anwendungsdaten\MailWasherPro\
  • delete Training archive - legitimate.rot135
  • restart MailWasher
User avatar
nick.bolton
The Big Cheese
Posts: 1779
Joined: Thu Aug 28, 2008 4:02 pm

Re: Access violation

Sat Dec 20, 2014 9:17 am

That's a really old version, but yes the training archive can become corrupted. We're now up to version 6.54 of that series which you can download from
http://www.firetrust.com/en/products/ma ... 6/download

Return to “Troubleshooting and Help for MailWasher 5 and 6”