Remove Account not removing accounts

Whether you're a MailWasher veteran or complete newbie, all users are welcome to get together. Discussions include usage and possible problems.
hello
Rattled Rabbit
Posts: 4
Joined: Wed Jan 27, 2010 12:14 am

Remove Account not removing accounts

Wed Jan 27, 2010 12:26 am

I've got a few expired domains about which I would like to remove email accounts and Tools/Accounts/remove account... does not remove anything.

I remove my accounts, then I see these accounts still in the check mail list and if I return back in Tools/Accounts they are back in the list.

Seems that Tools/Accounts/remove account... doesn't remove anything except temporarily the label in the email accounts list.
User avatar
stan_qaz
Omniscient Kiwi
Location: Gilbert, Arizona
Posts: 8671
Joined: Fri Jul 25, 2008 5:13 am

Re: Remove Account not removing accounts

Wed Jan 27, 2010 6:50 am

The accounts are stored in the registry, are you running any program that would prevent MW from editing the registry?
I am not a Firetrust employee just a MW user.
--
First rule of computer consulting: Sell a customer a Linux computer and you'll eat for a day,
sell a customer a Windows computer and you'll eat for a lifetime.
boongsong
Student Sheep
Posts: 22
Joined: Sun Nov 08, 2009 3:38 am

Re: Remove Account not removing accounts

Fri Jan 29, 2010 1:03 pm

I have a problem in the same area. I have 3 accts listed and want to remove one. When I click on the acct, then remove, MWP removes all accts. When I try to manually enter the right acct I keep getting the message the acct is already in MWP. Since I got my new computer I've had nothing but headaches trying to get MWP to work like it used to with XP/Outlook. Haven't found any fixes or any way to contact tech support to guide me so I'm just going to uninstall and start getting my mail via different acct. The ride was good while it lasted but I've had all the headaches/error messages/etc that I want.
hello
Rattled Rabbit
Posts: 4
Joined: Wed Jan 27, 2010 12:14 am

Re: Remove Account not removing accounts

Fri Jan 29, 2010 3:45 pm

stan_qaz wrote:The accounts are stored in the registry, are you running any program that would prevent MW from editing the registry?
Maybe the anti-virus?
System restore?

Where are these registry entries?
User avatar
stan_qaz
Omniscient Kiwi
Location: Gilbert, Arizona
Posts: 8671
Joined: Fri Jul 25, 2008 5:13 am

Re: Remove Account not removing accounts

Fri Jan 29, 2010 4:59 pm

In the registry. :-)

I'll give you a hint, try a search on mailwasher or firetrust and you should turn them up.

If you kill your system with regedit and don't have a backup to restore from... :-(
I am not a Firetrust employee just a MW user.
--
First rule of computer consulting: Sell a customer a Linux computer and you'll eat for a day,
sell a customer a Windows computer and you'll eat for a lifetime.
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 14045
Joined: Mon Jun 13, 2005 6:27 pm

Re: Remove Account not removing accounts

Fri Jan 29, 2010 5:12 pm

If you go to your MailWasher shortcut >> right click and select Properties >> and add a space then the text -restore to the very end of the command path, this will wipe all Registry Setting for MailWasher when you start the program.

if you do this, remember to remove the -restore afterwards, otherwise every time you start MailWasher the settings will wipe :)

I'll also work on a small Registry patch that will wipe only Accounts from the Registry
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 14045
Joined: Mon Jun 13, 2005 6:27 pm

Re: Remove Account not removing accounts

Fri Jan 29, 2010 5:18 pm

Account_purge.zip
(284 Bytes) Downloaded 359 times
Attached is a Registry file to run. If you execute this file with MailWasher closed, then answer Yes to import it into the Windows Registry, it will delete *all* accounts from MailWasher. Other settings however will be left intact.
hello
Rattled Rabbit
Posts: 4
Joined: Wed Jan 27, 2010 12:14 am

Re: Remove Account not removing accounts

Mon Feb 15, 2010 3:47 am

stan_qaz wrote:In the registry. :-)

I'll give you a hint, try a search on mailwasher or firetrust and you should turn them up.

If you kill your system with regedit and don't have a backup to restore from... :-(
Got them!
hello
Rattled Rabbit
Posts: 4
Joined: Wed Jan 27, 2010 12:14 am

Re: Remove Account not removing accounts

Sat Feb 20, 2010 8:24 pm

stan_qaz wrote:The accounts are stored in the registry, are you running any program that would prevent MW from editing the registry?
Makes sense. I've disabled my anti-virus and deleted some email accounts in MailWasher and it actually worked.

Thinking about it, there actually is a feature in my antivirus preventing programs to change the registry.

From now on, when I will be deleting email accounts in MailWasher, I will first disable my anti-virus, delete my accounts, and reactivate my anti-virus.
Tom_S
Rattled Rabbit
Posts: 2
Joined: Fri Oct 23, 2009 8:31 am

Re: Remove Account not removing accounts

Sun Jan 30, 2011 11:04 am

I've tried all of the above suggestions, to no avail. Here's what happened: I got a new computer with Windows 7, so I wanted to install mailwasher pro again. I downloded Pro 2011 instead of 6.5.4, set it up, then when I tried to register, it said my code was not valid. So I uninstalled 2011 & installed 6.5.4. Now I get the "index out of bounds" error. When I try to manually set up my email account, it says that it is already set up, but it's not. There are no accounts set up at all.

I did the "-restore" thing, and I did the "account purge" thing. I also went into the registry & deleted everything with "mailwasher" or "firetrust" in it. What else can I try?

Tom

Return to “Troubleshooting and Help for MailWasher 5 and 6”