Page 1 of 1

Troubleshooting broken file attachments

Posted: Sat Sep 18, 2010 4:33 pm
by sjmiller
I am looking for some guidance that would help me to solve a problem. I have been using Benign for a long time, and I have it successfully working on Windows 7. I find it to be a wonderful defense against the bad stuff. Recently I purchased a program to use with a security camera. This program can send an email alert with attached jpeg images. The problem is that the email is not coming through unchanged, even when I create a profile that has ALL options turned OFF. The attached images are renamed. If I bypass Benign, I can receive the message without a problem. As soon as I use Benign it breaks. The symptoms are these. The original email has multiple attached jpeg images. Each has a unique filename. It is a "long" file name. But it is valid. When the email passes through Benign, the long filename is lost and a short name is in its place. I believe that the short name is also a part of the message, otherwise Benign could not make this up. But unfortunately the short name has an incorrect file extension, and all the files have the same name. So only the long name is correct and unique. Why would Benign be stripping out the long name, and replacing it with the short name, even after I turned off every option on every page of the new profile I created and assigned to the mail account? I was hoping to find a single option to disable, so that I could maintain the remaining fetures of Benign. At this time, unless I can find another way, I have had to disable Benign and revert back to downloading my email directly from each account, without the protection of Benign. Please, help me to get Benign back in to my layered defenses.