B9 has stopped working

Troubleshooting and help for Benign.
Clay L
Student Sheep
Posts: 24
Joined: Tue Nov 25, 2008 5:14 am

B9 has stopped working

Sat Feb 07, 2009 4:09 am

A few months ago I upgraded from Mailwasher Free to Pro and installed B9.
It worked fine until a week or so ago.

All of a sudden I could not get my email.
Mailwasher could connect to the Compuserve POP server but Outlook Express couldn't. I had to remove the .b9 suffix from the account properties in Outlook Express to get my email. I added the .b9 suffix back the next day and I could get my email but the b9 footer no longer appears in the emails and the b9 log says it is not doing anything.
I reinstalled b9 and it didn't help.

I have XP sp3 and use Outlook Express. My email ISP is Compuserve and it is a POP type.

Any ideas of what might be wrong?

User avatar
Travelling Tuatara
Posts: 76
Joined: Tue Feb 24, 2009 8:54 am

Re: B9 has stopped working

Thu Feb 26, 2009 1:19 am

Hi Clay,

Sorry to hear that your having problems.

B9 is an especially rock solid product based upon my own (many) years of usage.

Generally speaking, whenever you have a program suddenly go belly up after a lengthy period of successful operation then it's reasonable to look elsewhere for possible causes. In this instance there are many possible reasons that might explain what you describe.

As an aside, Microsoft and most major IT players including CISCO and INTEL worked together to fix a major security flaw that was discovered in the design of the internet. As I recall they released a slew of updates and patches ... some of which weren't as well behaved as others. A clever guy called Kaminsky was among the first to identify it. Here are some links about the issue for anyone who might be interested ...

Seattle security expert helped uncover major design flaw on Internet - http://seattlepi.nwsource.com/local/373 ... ure04.html
Major Internet security flaw also affects e-mail - http://www.msnbc.msn.com/id/26091252/
A major flaw in the design of the Internet is being repaired by a large group of vendors. - http://www.technologyreview.com/web/21058/?a=f

In addition, Microsoft seems to release security fixes for office and XP so often that it is now a huge effort to reinstall (> 500 megs of patches for XP PRO alone). You can make life a little easier by using products like Windows Update Downloader (WUD) and nLite to slipstream these updates into new XP install disks. If anyone is interested in learning how to do this I'm happy to post the links.

Returning to your specific problem ... I use a simple process to troubleshoot ... perhaps it might be helpful for you too?
  • Define the problem and list 'symptoms'
    • B9 worked fine until it stopped suddenly
      MWP works fine but then it uses your normal mail server. This suggests that your system can access your email account quite happily.
      You reinstalled B9 and it still failed to work.
      • Did you uninstall it completely before reinstalling?
        Did you have another XP account logged in while trying to use B9 in your own account? B9 is sensitive and won't work properly if you have it set up on an account that is logged off but open.
        Did you make certain that you imported your email accounts once you reinstalled B9?
        Is it possible that someone else might have 'tinkered' with your B9 settings?
        Can you see B9 on the system tray? If not then it's not working and you won't be able to get your emails? It's easy to close it as opposed to minimise it.
        Does your email client (Outlook Express?) email account setting show the correct mail server settings after re-installation of B9?

        If all of the above seems OK then it's time to look elsewhere ...
    • Have you recently installed / upgraded your AV or internet security product?
      • Your firewall might be blocking B9 so you need to check it and give it access to the internet.
        I've seen this happen after a major security update from Microsoft and NIS (Norton Internet Security Suite) ... easily fixed.
        Make certain you are not running two software firewalls ... this is bad practice and can easily cause weird problems. Select one - whichever is best ... as in NIS or ZAPRO etc
    Run a full AV / malware check to make certain you have not got unwanted guests / viruses. You may have a bot or other malware.
    • Many hacker sites discuss how to disable your security ... sadly our risk exposure is becoming increasingly high.
      Equally sadly, I have observed a dramatic increase in drive-by downloads on websites. Some appear legitimate and all you need do is land on them and they plant all manner of nasties. NIS has a beta tool called Safe Web which automatically (and thoroughly) checks sites for phishing, malware and nasty practices. It works brilliantly.
This is off the top of my head. If you don't have any malware and you have installed B9 properly (including importing your email accounts) then it *should* work perfectly well.

If you have no malware etc then it's possible that your registry might be corrupted although this is not high on my list. There are other things to look at but they get a bit more involved ... best let us know how you go with the suggestions I've put forward.

I'm quite interested in how you go ... would you post back your status?


Not employed by FireTrust - just a happy long time user.
WIN 7 Pro - 64 bit (updated to max)
i7-2000K @ 3.9 Ghz - Geforce GTX 560 Ti SLI, 8 gig RAM
MOBO - GA-Z68XP-UD4 (rev 1)
Clay L
Student Sheep
Posts: 24
Joined: Tue Nov 25, 2008 5:14 am

Re: B9 has stopped working

Thu Feb 26, 2009 5:11 am

Hi Mike,

After reading your comprehensive answer I went back and checked a number of things. I found that the name of my account is
"pop.compuserve.com" and the incoming mail server has the same name. Somehow the .b9 suffix was added to the end of the account name and not the server.
I very well could have added it to the account name myself thinking I was adding it back to the server name. (I had removed it from the server name so I could get my email).
When I reinstalled B9 the account must not have been imported or the .b9 suffix would have been added to the end of the server name.

When I added it to the server name B9 started doing it's job.

Many thanks for the help.


Return to “Troubleshooting and Help”