greylist search does not work after upgraded to 3.0

Support forum for MailWasher Enterprise Server
cwh168998
Travelling Tuatara
Posts: 37
Joined: Wed Oct 28, 2015 4:10 am

greylist search does not work after upgraded to 3.0

Postby cwh168998 Wed Oct 28, 2015 7:56 am

I try to SEARCH FOR A QUARANTINED E-MAIL. or SEARCH FOR A GREY LISTED E-MAIL. The result is all empty. Only shows at SEARCH FOR E-MAIL TO TRACK DELIVERABILITY. So where is rescue in the new version?
User avatar
nick.bolton
The Big Cheese
Posts: 1740
Joined: Thu Aug 28, 2008 4:02 pm

Re: greylist search does not work after upgraded to 3.0

Postby nick.bolton Wed Oct 28, 2015 8:09 am

Hi

You can only rescue a quarantined or greylisted email. The 'ALL EMAILS' screen is just a log of all email passed through the system. If the email has been delivered then it won't show up in the quarantine or greylisting screen. If you find your email in the 'ALL EMAILS' screen, hover your mouse over the status column to see what happened to it.
cwh168998
Travelling Tuatara
Posts: 37
Joined: Wed Oct 28, 2015 4:10 am

Re: greylist search does not work after upgraded to 3.0

Postby cwh168998 Wed Oct 28, 2015 8:34 am

Thank you for reply.

The email shows in "all emails" as quarantined. But I can not find it in "quarantine email" or "greylist email". They are just empty.
User avatar
nick.bolton
The Big Cheese
Posts: 1740
Joined: Thu Aug 28, 2008 4:02 pm

Re: greylist search does not work after upgraded to 3.0

Postby nick.bolton Wed Oct 28, 2015 9:13 am

Ok, it seems to be working here for us :)

If it's been quarantined, then it won't be in the greylist screen, only the quarantine screen. There's a few other filters on that screen, can you make sure the TO, FROM, SUBJECT and DATE are correct - kind of obvious but had to ask.

Can you filter on another part of the email? Ie if you searched on the FROM, try the SUBJECT instead.
cwh168998
Travelling Tuatara
Posts: 37
Joined: Wed Oct 28, 2015 4:10 am

Re: greylist search does not work after upgraded to 3.0

Postby cwh168998 Thu Oct 29, 2015 8:22 am

The problem is: the email, It's been quarantined, but it's not showed in quarantined screen. The quarantine screen is always empty.
User avatar
nick.bolton
The Big Cheese
Posts: 1740
Joined: Thu Aug 28, 2008 4:02 pm

Re: greylist search does not work after upgraded to 3.0

Postby nick.bolton Thu Oct 29, 2015 8:34 am

Does the quarantine screen show any emails? I mean for all other quarantined emails. Or is it just this particular email?

If you have the logs set to High (Settings>>General>>Logging), can you send me the logs from
Windows: C:\Program Files\MailWasher Enterprise Server\logs
Linux: \var\log\mwes

to nick.bolton@firetrust.com and let me know what day and email address the quarantined email is from?

Thanks
cwh168998
Travelling Tuatara
Posts: 37
Joined: Wed Oct 28, 2015 4:10 am

Re: greylist search does not work after upgraded to 3.0

Postby cwh168998 Fri Oct 30, 2015 1:51 am

Thank you for the help.
The quarantine screen is totally empty. Not even one email listed there.
I will send the log file to your email. Thank you again.
User avatar
nick.bolton
The Big Cheese
Posts: 1740
Joined: Thu Aug 28, 2008 4:02 pm

Re: greylist search does not work after upgraded to 3.0

Postby nick.bolton Fri Oct 30, 2015 7:07 am

It looks like your database is missing a table, so perhaps somehow it became corrupted.

Error: QuarantinedTable::Add - failed - SQLite Error: sqlite3_prepare_v2 returned error code: 1 error message: table quarantined has no column named email_body_view
sql: insert into quarantined (email_from, email_to, email_subject, email_body, email_sourceip, quarantined_by_id, email_body_view) values (?, ?, ?, ?, ?, ?, ?);

Return to “MailWasher Enterprise Server”

Who is online

Users browsing this forum: No registered users and 1 guest