Web interface stop working after change listening IP

Support forum for MailWasher Enterprise Server
cwh168998
Travelling Tuatara
Posts: 36
Joined: Wed Oct 28, 2015 4:10 am

Web interface stop working after change listening IP

Postby cwh168998 Thu Nov 26, 2015 11:23 am

MY system crashed. I reinstalled SUSE 11.4 and mwesd 3.0.03(64).
The web interface was working fine when I first use 127.0.0.1, but it can only listening on server. So I changed it to 192.132.21.68. after I changed it and restarted mwesd, the web interface stopped working. I used netstat -nl to check. there is no port opening on 4044 any more. I checked /var/log/mwes/mail.log. there is no error. now I can not check or do any change to mwesd. Please help

part of the log file:
2015-11-25 17:09:41 [2766100256] Info: web_hostname::192.132.21.68
2015-11-25 17:09:41 [2766100256] Info: web_port::4044
2015-11-25 17:09:41 [2766100256] Info: DatabaseManager::UpgradeDatabase - version 37 ok
2015-11-25 17:09:41 [2766100256] Info: Open database....
2015-11-25 17:09:41 [2766100256] Info: Initialising database configure table....
2015-11-25 17:09:41 [2766100256] Info: Initialising database white listing table....
2015-11-25 17:09:41 [2766100256] Info: Initialising database black listing table....
2015-11-25 17:09:41 [2766100256] Info: Initialising database filter black listing table....
2015-11-25 17:09:41 [2766100256] Info: Initialising database filter white listing table....
2015-11-25 17:09:41 [2766100256] Info: Initialising database rbl listing table....
2015-11-25 17:09:41 [2766100256] Info: Initialising database quarantined table....
2015-11-25 17:09:41 [2766100256] Info: Initialising database gray listing table....
2015-11-25 17:09:41 [2766100256] Info: Initialising database white listing ip table....
2015-11-25 17:09:41 [2766100256] Info: Initialising database black listing ip table....
2015-11-25 17:09:41 [2766100256] Info: Initialising database user table....
User avatar
nick.bolton
The Big Cheese
Posts: 1627
Joined: Thu Aug 28, 2008 4:02 pm

Re: Web interface stop working after change listening IP

Postby nick.bolton Fri Nov 27, 2015 7:39 am

Can you go to MWES>>Settings>>Setup>>Check, and press the 'System Check' button. That will tell you what's wrong.
cwh168998
Travelling Tuatara
Posts: 36
Joined: Wed Oct 28, 2015 4:10 am

Re: Web interface stop working after change listening IP

Postby cwh168998 Tue Dec 01, 2015 8:32 am

Is there any other way to do it? Because the web page stopped working.
User avatar
nick.bolton
The Big Cheese
Posts: 1627
Joined: Thu Aug 28, 2008 4:02 pm

Re: Web interface stop working after change listening IP

Postby nick.bolton Tue Dec 01, 2015 8:37 am

Not really. Can you go to mwes.db in /opt/mwes and go to the configure table and you can change the web hostname there. If you leave it blank it will bind to all interfaces.

It's an SQLite database if you can find a tool online to access it.

Return to “MailWasher Enterprise Server”

Who is online

Users browsing this forum: No registered users and 1 guest