upgrade from 2.8 to 2.8.1

Address problems with the installation and initial configuration
Mystified Moa
Posts: 5
Joined: Thu Aug 13, 2009 11:50 pm

upgrade from 2.8 to 2.8.1

Sun Sep 02, 2012 7:45 am

I have been running 2.8.0 for some time now with great results. After getting the auto email for the subscription renewal, I see there is a newer version.

Downloaded and tried to install, which failed. So I stopped the mwes service and tried again. This time the install finished successfully.

However now I connont login via localhost:4044 (ie sayes page not available).

restarted server. MWES service would not start. manual stat (took 5 attempts). Still no login screen.

Re-installes 2.8.0 over the top. Still no login screen.

reinstalled 2.8.1 over the top (still no login screen)

lots of restarts in between.

Any suggestions would be gratefully received before monday, when everyone is back in the office


Desperate of Dorking
User avatar
The Big Cheese
Posts: 2468
Joined: Thu Aug 28, 2008 4:02 pm

Re: upgrade from 2.8 to 2.8.1

Tue Sep 11, 2012 7:42 pm

As per email.

It sounds like you've set an incorrect IP to bind to in the configuration.
The error it's giving typically indicates that the service is unable to bind to the IP provided, as it doesnt exist on the server itself - this often happens when someone sets an external IP or name, when the server itself is an internal address, using NAT to connect to the outside world.

The logs will indicate what IP it's attempting to bind to when starting up - look for the entry web_address .... or similar.

If you can not access the control panel via the web browser, the only way to fix it is to remove the IP value from he database.
This requires you to download and install the sqlite CLI application, and edit it using SQL commands.

Return to “Installation”