No Qmail support?

Well, it's up and running, but I'm not sure if it's doing what it should.
User avatar
ajt
would rather be watching cricket
Contact:
Location: Auckland, New Zealand
Posts: 62
Joined: Mon Jan 19, 2009 4:24 pm

Re: No Qmail support?

Tue Jun 02, 2009 9:01 am

Hi,

For uninstalling Old Mail Washer Server follow the instructions at

http://www.firetrust.com/support/mailwa ... index.html?
how_mailwasher_server_filters_messages.htm

Follow the instructions on README for MWES Proxy Version installation.

Cheers
User avatar
nick.bolton
The Big Cheese
Posts: 1975
Joined: Thu Aug 28, 2008 4:02 pm

Re: No Qmail support?

Tue Jun 02, 2009 1:36 pm

Actually, here's the correct link as it didn't resolve properly http://www.firetrust.com/support/mailwa ... lation.htm
mikelawford
Travelling Tuatara
Posts: 27
Joined: Tue Apr 07, 2009 10:56 pm

Re: No Qmail support?

Thu Jun 18, 2009 12:09 am

Hi - I have finally gotten around to doing this. Sorry for the delay!

I have installed OK and when i login I see System status: ok... So all good so far. But I cannot get the monitoring to work when I click on 'monitor' or 'quarentine' it just shows blank.

As per the readme I have changed mta_port=26, use_mta_proxy=1 and working_domains=fresh-value.net - and the restarted 'mwesd'

Also - how do I setup the user lists and user logins here?
User avatar
ajt
would rather be watching cricket
Contact:
Location: Auckland, New Zealand
Posts: 62
Joined: Mon Jan 19, 2009 4:24 pm

Re: No Qmail support?

Thu Jun 18, 2009 11:31 am

Hi,

Which mwes ver you installed? Latest stable release is 2.6.11. Have you gone through Readme before installation and changed Qmail port to 26?

---I have installed OK and when i login I see System status: ok... So all good so far. But I cannot get the monitoring to work when I click on 'monitor' or 'quarentine' it just shows blank.---

From above statement you mean monitor stats are 0? What does processed emails says?

2.6.11 is supporting 1 global user account which can be setup from Admin Panel->Settings->User. Next mwes release will have multiple users feature.

Cheers
mikelawford
Travelling Tuatara
Posts: 27
Joined: Tue Apr 07, 2009 10:56 pm

Re: No Qmail support?

Thu Jun 18, 2009 8:59 pm

I have installed ver 2.6.10 as per Nicks instructions.

Processed / monitor and quarentined emails are both 0 so it obviously aint processing - all spam is flying through. All I have done was install and do as the readme says - edit the conf file to try and get the proxy to work and changed:

mta_port=26, use_mta_proxy=1 and working_domains=fresh-value.net - and the restarted 'mwesd'

So how do my users check for false positives? Or do all emails on the domain go through one account?

Thanks,
Mike
User avatar
ajt
would rather be watching cricket
Contact:
Location: Auckland, New Zealand
Posts: 62
Joined: Mon Jan 19, 2009 4:24 pm

Re: No Qmail support?

Thu Jun 18, 2009 9:21 pm

Hi,

You can download 2.6.11 from
http://s3.amazonaws.com/Firetrust/mwes/mwes-2611.tar.gz

You have to change MTA smtp port to 26. MWES is working as a proxy and will talk to MTA at port 26.
Following links may help:

http://qmail.jms1.net/scripts/service-q ... -run.shtml
http://www.linuxhomenetworking.com/foru ... .php?t=666
Current releases do have one global user account and it can be used by all users to rescue emails. Multiple user accounts is ready for next major release.

Cheers
mikelawford
Travelling Tuatara
Posts: 27
Joined: Tue Apr 07, 2009 10:56 pm

Re: No Qmail support?

Thu Jun 18, 2009 9:29 pm

OK I will upgrade that for you. But I have already changed MTA to be the SMTP port havent I - by setting mta_port=26?

So it should work but nothing is being processed?
User avatar
ajt
would rather be watching cricket
Contact:
Location: Auckland, New Zealand
Posts: 62
Joined: Mon Jan 19, 2009 4:24 pm

Re: No Qmail support?

Thu Jun 18, 2009 9:42 pm

Hi,
mta_port=26 is parameter in mwes.conf which says mwes will talk to MTA (Qmail, Sendmail etc.) on this port, don't have to change it.

You have to change the smtp port of MTA (Qmail or Sendmail) from 25 to 26.
Visit following links for help.
http://qmail.jms1.net/scripts/service-q ... -run.shtml
http://www.linuxhomenetworking.com/foru ... .php?t=666

Cheers
mikelawford
Travelling Tuatara
Posts: 27
Joined: Tue Apr 07, 2009 10:56 pm

Re: No Qmail support?

Fri Jun 19, 2009 12:21 am

OK I have looked and understand what is needed. Problem is that I cant find the place where I must update port=25 to port=26.

Which file is this located in. I am using RH Linux and qmail operated with Plesk.

Any ideas?
User avatar
ajt
would rather be watching cricket
Contact:
Location: Auckland, New Zealand
Posts: 62
Joined: Mon Jan 19, 2009 4:24 pm

Re: No Qmail support?

Fri Jun 19, 2009 12:36 am

Usually it is in "qmail-smtpd" file.

Remote installation can be provided by firetrust if needed.
mikelawford
Travelling Tuatara
Posts: 27
Joined: Tue Apr 07, 2009 10:56 pm

Re: No Qmail support?

Fri Jun 19, 2009 12:47 am

Sure how much?

I followed the instructions at http://supportfacility.com/blog/plesk/p ... e-port-26/ and can now report that :

[root@blackbob xinetd.d]# netstat -anp | grep xinetd
tcp 0 0 0.0.0.0:106 0.0.0.0:* LISTEN 28865/xinetd
tcp 0 0 0.0.0.0:465 0.0.0.0:* LISTEN 28865/xinetd
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 28865/xinetd
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 28865/xinetd
tcp 0 0 0.0.0.0:26 0.0.0.0:* LISTEN 28865/xinetd
unix 2 [ ] DGRAM 1810431 28865/xinetd


But still when I enter MWES no mails are being processed...
User avatar
ajt
would rather be watching cricket
Contact:
Location: Auckland, New Zealand
Posts: 62
Joined: Mon Jan 19, 2009 4:24 pm

Re: No Qmail support?

Fri Jun 19, 2009 1:04 am

tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 28865/xinetd
tcp 0 0 0.0.0.0:26 0.0.0.0:* LISTEN 28865/xinetd

It is listening to port 25 also which should not be the case. Qmail should only listen on port 26.
mikelawford
Travelling Tuatara
Posts: 27
Joined: Tue Apr 07, 2009 10:56 pm

Re: No Qmail support?

Fri Jun 19, 2009 1:12 am

AND I cant seem to switch the mwesd on?

[root@blackbob init.d]# /sbin/chkconfig mwesd on
service mwesd does not support chkconfig
??
mikelawford
Travelling Tuatara
Posts: 27
Joined: Tue Apr 07, 2009 10:56 pm

Re: No Qmail support?

Fri Jun 19, 2009 1:16 am

t is listening to port 25 also which should not be the case. Qmail should only listen on port 26.

Thanks - so we getting there. So how do I get rid of that - I am happy to pay Firetrust if you want to finish the install - cost?

If I try and nano "qmail-smtpd" I get garbage so have to do this another way.
User avatar
ajt
would rather be watching cricket
Contact:
Location: Auckland, New Zealand
Posts: 62
Joined: Mon Jan 19, 2009 4:24 pm

Re: No Qmail support?

Fri Jun 19, 2009 1:18 am

mwesd is written to cater all linux flavors and standard for daemons are /etc/init.d/ and redhat uses /etc/rc.d/init.d
Did you copy mwesd in init.d folder?

Return to “Post Installation”