Remove or hide footer info in MWES

Well, it's up and running, but I'm not sure if it's doing what it should.
triadgroup
Rattled Rabbit
Posts: 3
Joined: Wed May 12, 2010 3:51 am

Remove or hide footer info in MWES

Wed May 12, 2010 4:54 am

After installing and configuring the mwes, I have noticed that it adds the following to each email:

X-MWES-scanned: Checked by MailWasher Enterprise Server 2.7.6 {U}(2010-05-11 15:38:42)
X-MWES-status: Clean
X-MWES-reason: Local IP
X-MWES-sourceip: 192.168.2.16
X-MWES-smtp-from: <john@jctechwi.com>

How do I hode them in the headers. Our employees are not going to want that displayed after their signatures.
User avatar
nick.bolton
The Big Cheese
Posts: 1815
Joined: Thu Aug 28, 2008 4:02 pm

Re: Remove or hide footer info in MWES

Wed May 12, 2010 12:00 pm

just replying here, also in email

The X-MWES headers are in the header section of the email, they are never shown in the body.

What is your setup server side and client side?

Can you give us an example?
We’ve seen this before with qmail (MTA) not setup correctly, so we can have a look at this if you like.
User avatar
nick.bolton
The Big Cheese
Posts: 1815
Joined: Thu Aug 28, 2008 4:02 pm

Re: Remove or hide footer info in MWES

Thu May 13, 2010 11:05 am

Just recreated the problem.
When using telnet you're not using new line after entering command DATA. This separates the header from the body example.
Note new line is required and is done automatically by mail clients.


S: 220 smtp.example.com ESMTP Postfix
C: HELO relay.example.org
S: 250 Hello relay.example.org, I am glad to meet you
C: MAIL FROM:<bob@example.org>
S: 250 Ok
C: RCPT TO:<alice@example.com>
S: 250 Ok
C: RCPT TO:<theboss@example.com>
S: 250 Ok
C: DATA
S: 354 End data with <CR><LF>.<CR><LF>
C:
C: Hello Alice.
C: This is a test message with 0 header fields and 4 lines in the message body.
C: Your friend,
C: Bob
C: .
S: 250 Ok: queued as 12345
C: QUIT
S: 221 Bye

Return to “Post Installation”