mwes application crash

Problems/tips/tricks with MailWasher Enterprise, Windows and Exchange
ip67
Rattled Rabbit
Posts: 3
Joined: Tue Dec 07, 2010 12:44 pm

mwes application crash

Postby ip67 Tue Dec 07, 2010 12:57 pm

Hi.
I have a client site running the current version of Mail Washer Enterprise Server (2.7.81).
They've been using it successfully for about 6 months - recently, we are seeing multiple crashes of mwes.exe. They eventually lead to the application hanging and all email delivery ceases until the server is fixed. SOmetimes we can successfully stop and restart the service. Other times it completely hangs, and the quickest solution seems to be rebooting the server.

Event Log info is;
Event 1000
Faulting application mwes.exe, version 0.0.0.0, faulting module mwes.exe, version 0.0.0.0, fault address 0x000b341c.

This behaviour seems to be becoming more frequent. It's a very static site, with no new software installed on the server. They are running SBS 2003 with Exchange 2003 SP2 and Trend Micro 'Worry Free Business'.

I'm aware of similar posts here already - but they appear to be quite old, with the resolution to upgrade to the latest version ... not really possible in this case!

If anyone is aware of a resolution to this problem - or even if it's a know issue with some kind of work-around, could you let me know?
Thanks.
User avatar
nick.bolton
The Big Cheese
Posts: 1647
Joined: Thu Aug 28, 2008 4:02 pm

Re: mwes application crash

Postby nick.bolton Tue Dec 14, 2010 7:42 am

Sorry for the very late reply, can you email nick.bolton@firetrust.com with the logs (in the log directory where you installed it). I'll be able to look at the logs and if my assumptions are correct be able to send you back a fix.

Thanks
cliff
Evil Firetrust Employee
Posts: 31
Joined: Tue Jul 28, 2009 3:50 pm

Re: mwes application crash

Postby cliff Wed Dec 15, 2010 1:14 pm

Hi there,

While the messages are annoying, they are benign – as the MWES service restarts on a crash.
We have made changes in the new upcoming release to fix a crash bug, which we will release early in the new year.

~ C
recordprinting
Rattled Rabbit
Posts: 3
Joined: Tue Jan 18, 2011 3:31 am

Re: mwes application crash

Postby recordprinting Tue Jan 18, 2011 3:41 am

I don't find this issue to be benign every morning since I installed the latest update the mwes.exe crashes constantly and all our emails seem to be held up not sure if it is in the exchange server or in the mailwasher server but they do not get delivered until I manually click on all the messages some times 50+ that are telling me can not reference memory at location XYZ.

I have completely uninstalled and reinstalled the mailwasher server but got the same results.

Please let me know where to find and who to send log files to if you would like to look at them or if I can try a beta of the next release as I have disabled the server for the time being.

Thank you for your time,

Mike
User avatar
nick.bolton
The Big Cheese
Posts: 1647
Joined: Thu Aug 28, 2008 4:02 pm

Re: mwes application crash

Postby nick.bolton Tue Feb 01, 2011 7:12 am

Really sorry for the late reply Mike

You can find the log files in the same directory as the place you installed it. We've got a new version which fixes this and we'll be releasing it soon if you want to try it.
http://firetrust.com/sites/firetrust.co ... ler-28.exe

Nick
recordprinting
Rattled Rabbit
Posts: 3
Joined: Tue Jan 18, 2011 3:31 am

Re: mwes application crash

Postby recordprinting Tue Feb 01, 2011 7:19 am

Thank you Nick,

I actually PM'd Cliff a few weeks ago and got a copy of the latest version. It seems to have resolved my issues.

Thank you,

Mike
ip67
Rattled Rabbit
Posts: 3
Joined: Tue Dec 07, 2010 12:44 pm

Re: mwes application crash

Postby ip67 Fri Feb 18, 2011 12:11 pm

It's my turn to apologise for a late reply - sorry.
This app crash has continued on an intermittent level. I'm not sure that it's not a memory leak of some sort - it seems to be more prevalent after the server has been running without a reboot over some days or weeks.
I'm hesitant to install a non-release version of MailWasher in a production environment - is version 28 'safe' to install?
Is it worth waiting for it's official release?
Thanks for the input.
ip67
Rattled Rabbit
Posts: 3
Joined: Tue Dec 07, 2010 12:44 pm

Re: mwes application crash

Postby ip67 Thu Mar 10, 2011 4:27 pm

Hi Nick.
I hope you're all OK and getting things back together there.
My client site has continued to have crashing problems with MWES, causing inbound email to halt until the service is manually killed and restarted.
In desperation I have installed v28, although I was hesitant to do so in a production environment. Hearsay seems to indicate the beta version is stable for deployment.
It installed OK, but it now says that it failed toi migrate the license.
Can you advise how to rectify this?

Thanks.
Regards, Iain Penman.
User avatar
nick.bolton
The Big Cheese
Posts: 1647
Joined: Thu Aug 28, 2008 4:02 pm

Re: mwes application crash

Postby nick.bolton Thu Mar 10, 2011 4:30 pm

Hi Iain

We'll actually be releasing this version next week and it's proven stable for many other customers over the past 3 months. I'll send a license key to you via email so you can continue to use it.

Regards
Nick

Return to “Windows Specific”

Who is online

Users browsing this forum: No registered users and 1 guest