MWES with Scalix

Problems/tips/tricks with MailWasher Enterprise and Linux
easysoft
It begins with a single step
Posts: 1
Joined: Tue Aug 04, 2009 9:06 pm

MWES with Scalix

Postby easysoft Tue Aug 04, 2009 9:13 pm

Hi All,

I'm trying to use MailWasher ES with Scalix 11.4.

I have had Scalix running fine, using Sendmail Milter for Amavisd-new (virus scanning) and MIMEDefang for a 'boilerplate'.
I now want to add MailWasher ES. The basic problem is this :

In its standard configuration, Scalix listens on port 25 and then forwards all emails to Sendmail. When Sendmail passes the email to MWES (using milter) the source IP always appears as localhost, so MWES always PASSes the email.

To avoid this, I needed to change the Scalix config so that sendmail listens on port 25, and then forwards to Scalix. This caused problems with authentication when sending mail from Outlook as well as Scalix Webmail.

Has anyone else had this problem? Any HOWTOs on the subject? I have put up a message on the scalix forums :

http://www.scalix.com/forums/viewtopic.php?f=9&t=13856

Regards & thanks in advance,
Arif
User avatar
ajt
would rather be watching cricket
Posts: 62
Joined: Mon Jan 19, 2009 4:24 pm
Location: Auckland, New Zealand
Contact:

Re: MWES with Scalix

Postby ajt Wed Aug 05, 2009 6:18 pm

You could try running MWES as a proxy in front of Scalix

MWES Proxy (SMTP port 25) -> Scalix MTA/Relay(Port 26) -> Sendmail (Port 27)

The Readme file will explain this just replace the wording for MTA with Scalix

Change mwes.conf
use_mta_proxy=1

Remove the sendmail milter interface. Then stop/start MWES.

Curently MWES proxy is not support SSL/TLS connections.

Cheers

Return to “Linux Specific”

Who is online

Users browsing this forum: No registered users and 1 guest