Missing emails

Forum for MailWasher Pro 7 and/or older 2011/2012 versions.
Rahosi
Student Sheep
Posts: 11
Joined: Thu Sep 13, 2012 8:59 pm

Missing emails

Postby Rahosi Tue Jun 12, 2018 9:40 pm

Pro 7.11.5 Win10x64pro Windows Defender & all up to date, Malwarebytes.

This is not a new problem and has existed before & after clean Windows installs & refreshes. Been away for a few days with PC off. Only 1 email (Gmail System message) is showing in the message list for those away days; Dozens of 'Inbox' messages are missing. This applies to numerous email accounts, including some Gmail accounts and private servers. Have tried Clearing The Message List. Those emails show in Outlook, web interfaces and on my Android phone (Aquamail).
User avatar
rusticdog
Firetrust Monkey
Posts: 13516
Joined: Mon Jun 13, 2005 6:27 pm
Contact:

Re: Missing emails

Postby rusticdog Tue Jun 12, 2018 10:17 pm

Hi there

Under Settings >> Accounts >> Incoming >> is your GMail set to POP or IMAP ?

If it is POP, then you could switch to IMAP, which would load all Unread emails in the INBOX folder.
If you want to stick with POP, then you could try using Recent Mode, which is a GMail feature. TO use this you add recent: to your username, so for example if your username was test_email_address@gmail.com you would change it to
recent:test_email_address@gmail.com

From memory, Recent Mode loads the last 30 days of messages.
Rahosi
Student Sheep
Posts: 11
Joined: Thu Sep 13, 2012 8:59 pm

Re: Missing emails

Postby Rahosi Wed Jun 13, 2018 12:30 am

I use IMAP for my accounts everywhere
User avatar
rusticdog
Firetrust Monkey
Posts: 13516
Joined: Mon Jun 13, 2005 6:27 pm
Contact:

Re: Missing emails

Postby rusticdog Wed Jun 13, 2018 12:49 am

OK. I would then try removing the account from MailWasher, restart, add it back in. It should be able to import from Outlook.
Rahosi
Student Sheep
Posts: 11
Joined: Thu Sep 13, 2012 8:59 pm

Re: Missing emails

Postby Rahosi Wed Jun 13, 2018 12:53 am

It is not just one account, it is all 7 of my email accounts. Thus I guess a program fault
User avatar
rusticdog
Firetrust Monkey
Posts: 13516
Joined: Mon Jun 13, 2005 6:27 pm
Contact:

Re: Missing emails

Postby rusticdog Wed Jun 13, 2018 12:59 am

Oh. How odd.

Can you try sending me some logs. If you go Help >> Send Support Logs >> enter a brief note like 'gmail not loading email' >> in the Ticket Number field enter chris >> Send Logs.

Reply back once sent, so I know to be on the lookout for them.

Thanks.
Rahosi
Student Sheep
Posts: 11
Joined: Thu Sep 13, 2012 8:59 pm

Re: Missing emails

Postby Rahosi Wed Jun 13, 2018 1:03 am

Done - Numerous email A/Cs not loading emails from when computer switched off
User avatar
rusticdog
Firetrust Monkey
Posts: 13516
Joined: Mon Jun 13, 2005 6:27 pm
Contact:

Re: Missing emails

Postby rusticdog Wed Jun 13, 2018 1:34 am

OK, oddly nothing is standing out.

I would first restart MailWasher, as logs shows those first emails coming in..

If you have an Anti Virus with an email scanner module, I'd disable that and see if it makes any difference. Though I would not expect so, given the logs looking clean. If you want to speed things up a touch too, before you restart MW go into Settings >> Spam Tools >> Origin of Spam >> and uncheck the DNSBLs there.

If that doesn't help, I would try emptying the Recycle Bin in MailWasher, then restart it again.
Rahosi
Student Sheep
Posts: 11
Joined: Thu Sep 13, 2012 8:59 pm

Re: Missing emails

Postby Rahosi Wed Jun 13, 2018 2:39 am

Only security software is Windows Defender & Malwarebytes.
(Computer is high spec. X299, i7-7820X, 32Gb RAM Samsung SSD 960pro 1TB, so pretty fast)
Followed your suggestions. Most but not all accounts are now displaying their missing emails. Repeated the restart 3 times with no further improvement.
I also note that new positive Classifications on old mysteriously unclassified emails are not sticking
User avatar
rusticdog
Firetrust Monkey
Posts: 13516
Joined: Mon Jun 13, 2005 6:27 pm
Contact:

Re: Missing emails

Postby rusticdog Wed Jun 13, 2018 2:53 am

Sounds like something screwed in the database.

You could first try removing the problem accounts, restart MailWasher, add them back in.

If that fails, then you could go into Help >> User Files >> close down MailWasher >> back in the folder open cache folder >> rename crypto to something like oldcrypto >> start MailWasher. Note though that this process wipes Recycle Bin and what emails you've trained as good and spam, so you'll need to start the training again.
Rahosi
Student Sheep
Posts: 11
Joined: Thu Sep 13, 2012 8:59 pm

Re: Missing emails

Postby Rahosi Wed Jun 13, 2018 3:15 am

Removing & adding problem A/Cs back in fixed the problem. THANKS!

Have had this issue a few times before. Think others have had it too. Any chance this being resolved when V8 released?
User avatar
rusticdog
Firetrust Monkey
Posts: 13516
Joined: Mon Jun 13, 2005 6:27 pm
Contact:

Re: Missing emails

Postby rusticdog Wed Jun 13, 2018 4:06 am

Yeah I think we'll be reworking the cache/database system :) Glad to know it's sorted now.

Cheers

Return to “MailWasher Pro 7”

Who is online

Users browsing this forum: Baidu [Spider] and 4 guests