[SOLVED = PIPELINING to OFF] Need multiple refreshes to get mails

Forum for MailWasher Pro 7 and/or older 2011/2012 versions.
zilog256
Rattled Rabbit
Posts: 3
Joined: Thu Nov 28, 2019 10:49 am

[SOLVED = PIPELINING to OFF] Need multiple refreshes to get mails

Thu Nov 28, 2019 10:56 am

Hello.

Been using MWP with great pleasure for quite some time : I have 4 accounts on a regular ISP, I use POP to retrieve the emails.

Since a week or so, I was surprised to see a bunch of junkmail when opening my regular mail-reader after doing a preread and wash with MWP, as usual.

MWP listed dozens of spams and deleted them, still, I had a whole lot of them in the mailer afterwards.

After some investigating, I uncovered the strange behavior as is :

- I launch MWP, it reads let's say 100 mails on the 4 accounts, 20 OK, 80 as junk, I delete them.

- Then if I press the "read mail" button, EACH TIME, I will get ONE new junkmail arriving, repeating the process mail by mail, up to something like 25 times.

- Then I delete and it's ok, no more junkmails.

I tried this today and also saw that the trashbin was not emptied (I never do it) ; maybe that's the whole thing (?)

I'll check tomorrow and see if the same behavior continues now that the trashbin was emptied.

:scratch
Last edited by zilog256 on Fri Nov 29, 2019 5:24 am, edited 1 time in total.
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 14306
Joined: Mon Jun 13, 2005 6:27 pm

Re: Need multiple refreshes to get mails

Thu Nov 28, 2019 10:59 am

For the problem account, check under Settings >> Accounts >> Incoming >> is the account set to POP at the top ?
If so, click Advanced >> uncheck the option to Use PIPELINING when Checking Mail >> Save.
zilog256
Rattled Rabbit
Posts: 3
Joined: Thu Nov 28, 2019 10:49 am

Re: Need multiple refreshes to get mails

Thu Nov 28, 2019 11:12 am

Thanks for the quick answer.

Yes of course POP3 is selected, classic port 110, secure connection ,and PIPELINING is ON by default.

Until recently everything worked perfectly fine. Maybe something has changed on the server/ISP side.
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 14306
Joined: Mon Jun 13, 2005 6:27 pm

Re: Need multiple refreshes to get mails

Thu Nov 28, 2019 11:15 am

Possibly yes, we found this issue to be more common with certain ISPs.

You shouldn't notice much difference with the PIPELINING off, MailWasher will check messages a touch slower, but that's all.

Cheers
zilog256
Rattled Rabbit
Posts: 3
Joined: Thu Nov 28, 2019 10:49 am

Re: Need multiple refreshes to get mails

Fri Nov 29, 2019 5:24 am

Ticking "pipeling" as OFF does the trick indeed. And no noticeable slowdown.

A bit weird but as long as there is a solution/parameter it's fine.

Thanks!

Return to “MailWasher Pro 7”