Old Update Bug

Forum for MailWasher Pro 7 and/or older 2011/2012 versions.
User avatar
Duck
Active Albatross
Posts: 189
Joined: Thu Jul 08, 2010 4:07 am

Old Update Bug

Sun Oct 09, 2011 7:10 am

I thought it was fixed but I think I still have the same issue. I never got an update notice from within MWP (1.2.0) that there was a new update. After getting RD's message that there was an update, I tried but it says that I am up to date. I know that I'm now and I know that I can update manually. Is there a "fix" that I missed to get the update notice or to at least find the update when checking for updates?

Duck
User avatar
stan_qaz
Omniscient Kiwi
Location: Gilbert, Arizona
Posts: 8671
Joined: Fri Jul 25, 2008 5:13 am

Re: Old Update Bug

Sun Oct 09, 2011 7:29 am

If you have MW 2011 v 1.2.0 set to check for updates it should be doing that, you might look at your settings to see how often it is checking.

I subscribe to the update topic here so I get e-mails from the forum once rusticdog updates the post about a new version.
updates.png
Default is a weekly check
updates.png (23.52 KiB) Viewed 4026 times
I am not a Firetrust employee just a MW user.
--
First rule of computer consulting: Sell a customer a Linux computer and you'll eat for a day,
sell a customer a Windows computer and you'll eat for a lifetime.
User avatar
Sidewinder
Weary Womble
Posts: 11678
Joined: Sun Mar 29, 2009 2:05 pm

Re: Old Update Bug

Sun Oct 09, 2011 7:37 am

If you don't resolve it with Stan's information then I suggest using the "Go To Folder" hotlink shown in Stan's screen cap and delete the updates.aiu file then go to Help, Check for Updates.
I am not a Firetrust employee. Just a MW User & Volunteer BETA Tester.
Remember "FREEDOM IS NEVER FREE" U.S.N.
DT W7 64 HP SP1 16GB Ram - LT W7 32 HP SP1 4GB Ram - iPad4 64 GB Ram WiFi/Cellular IOS 9.3 Beta 3
User avatar
Duck
Active Albatross
Posts: 189
Joined: Thu Jul 08, 2010 4:07 am

Re: Old Update Bug

Sun Oct 09, 2011 7:58 am

stan_qaz wrote:If you have MW 2011 v 1.2.0 set to check for updates it should be doing that, you might look at your settings to see how often it is checking.
I'm set up to auto check every 2 days.
stan_qaz wrote:I subscribe to the update topic here so I get e-mails from the forum once rusticdog updates the post about a new version.
updates.png
That is what I said above...that I got the notice from RD (i.e. I'm subscribed as well and that is how I knew that there was an update).
User avatar
Duck
Active Albatross
Posts: 189
Joined: Thu Jul 08, 2010 4:07 am

Re: Old Update Bug

Sun Oct 09, 2011 8:01 am

Sidewinder wrote:If you don't resolve it with Stan's information then I suggest using the "Go To Folder" hotlink shown in Stan's screen cap and delete the updates.aiu file then go to Help, Check for Updates.
Yeppers...that is what I mentioned above as well...I know how to get the update but I would like it to work as advertised (i.e. inform me every two days as set or at least update when I tell it to and there is a new one out there).

I'm going to hold off updating until I hear if there is a fix for this. So far, it's all been really good. One thing that I have considered is doing a clean install. I have always "updated" rather than clean installed in the past. In the past, I have always deleted the updates.aiu file to get the update so I know that works.

Thanks for the inputs.

Duck
User avatar
Sidewinder
Weary Womble
Posts: 11678
Joined: Sun Mar 29, 2009 2:05 pm

Re: Old Update Bug

Sun Oct 09, 2011 8:25 am

V1.3 is a full install rather than a patch.
I am not a Firetrust employee. Just a MW User & Volunteer BETA Tester.
Remember "FREEDOM IS NEVER FREE" U.S.N.
DT W7 64 HP SP1 16GB Ram - LT W7 32 HP SP1 4GB Ram - iPad4 64 GB Ram WiFi/Cellular IOS 9.3 Beta 3
User avatar
Duck
Active Albatross
Posts: 189
Joined: Thu Jul 08, 2010 4:07 am

Re: Old Update Bug

Sun Oct 09, 2011 4:26 pm

It seemed to work find with an auto update on my Windows 7 (x64 Bit). It looks like just the Vista is having the issues.
User avatar
TrustFire
βeta Tester
Location: 127.0.0.1
Posts: 12735
Joined: Fri Jul 30, 2010 11:04 pm

Re: Old Update Bug

Sun Oct 09, 2011 5:20 pm

Hope your MWP auto-update has not been firewalled (unknowingly) in Vista. :scratch
MWP 7 (ßeta) | Windows 10 Pro (x64) | The Bat! Professional (ßeta) | Windows 10 Firewall Control (ßeta) | ESET Endpoint Antivirus (ßeta) | NVIDIA GeForce GTX 1060 | Internet Connection Speed (D=50 Mb/s, U=3.5 Mb/s) | .NET Framework (4.8)
User avatar
Sidewinder
Weary Womble
Posts: 11678
Joined: Sun Mar 29, 2009 2:05 pm

Re: Old Update Bug

Mon Oct 10, 2011 12:04 am

You may need to make sure that the updater.exe for MWP is "trusted".
I am not a Firetrust employee. Just a MW User & Volunteer BETA Tester.
Remember "FREEDOM IS NEVER FREE" U.S.N.
DT W7 64 HP SP1 16GB Ram - LT W7 32 HP SP1 4GB Ram - iPad4 64 GB Ram WiFi/Cellular IOS 9.3 Beta 3
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 14170
Joined: Mon Jun 13, 2005 6:27 pm

Re: Old Update Bug

Mon Oct 10, 2011 1:11 pm

Duck wrote:
Sidewinder wrote:If you don't resolve it with Stan's information then I suggest using the "Go To Folder" hotlink shown in Stan's screen cap and delete the updates.aiu file then go to Help, Check for Updates.
Yeppers...that is what I mentioned above as well...I know how to get the update but I would like it to work as advertised (i.e. inform me every two days as set or at least update when I tell it to and there is a new one out there).

I'm going to hold off updating until I hear if there is a fix for this. So far, it's all been really good. One thing that I have considered is doing a clean install. I have always "updated" rather than clean installed in the past. In the past, I have always deleted the updates.aiu file to get the update so I know that works.

Thanks for the inputs.

Duck
So if you've still got the older version installed, can you try a check for updates then send me some logs ? Help >> Send Support Logs >> put chris as Ticket Number and note like 'won't update' >> Send Logs.


Cheers
User avatar
Duck
Active Albatross
Posts: 189
Joined: Thu Jul 08, 2010 4:07 am

Re: Old Update Bug

Tue Oct 11, 2011 9:47 pm

TrustFire wrote:Hope your MWP auto-update has not been firewalled (unknowingly) in Vista. :scratch
Nope...it is allowed to pass. Excellent catch though.
User avatar
Duck
Active Albatross
Posts: 189
Joined: Thu Jul 08, 2010 4:07 am

Re: Old Update Bug

Tue Oct 11, 2011 9:47 pm

Sidewinder wrote:You may need to make sure that the updater.exe for MWP is "trusted".
It is trusted...thanks.
User avatar
Duck
Active Albatross
Posts: 189
Joined: Thu Jul 08, 2010 4:07 am

Re: Old Update Bug

Tue Oct 11, 2011 9:49 pm

rusticdog wrote:So if you've still got the older version installed, can you try a check for updates then send me some logs ? Help >> Send Support Logs >> put chris as Ticket Number and note like 'won't update' >> Send Logs.


Cheers
Thanks RD. it's on the way. Oh...and BTW, remind me to NEVER try to take a nap anywhere near you and your camera! Has she found out yet? :devil
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 14170
Joined: Mon Jun 13, 2005 6:27 pm

Re: Old Update Bug

Wed Oct 12, 2011 2:45 am

She is a very forgiving woman....I don't know why, that just tells me I haven't gone far enough :crazy


Here's what's going on, in short MailWasher seemingly cannot overwrite, delete, replace, take ownership or do anything really with the updates file.
10-11-2011 04:50:16.505 MWPUI Manually checking for updates
10-11-2011 04:50:16.521 MWPUI Udating INI file
10-11-2011 04:50:16.521 MWPUI Loading INI config options
10-11-2011 04:50:16.536 MWPUI Updating app directory
10-11-2011 04:50:16.536 MWPUI Path to updates.aiu file: C:\ProgramData\Firetrust\updates\updates.aiu
10-11-2011 04:50:16.536 MWPUI Deleting updates.aiu file
10-11-2011 04:50:16.552 MWPUI Could not delete file, try setting ownership
10-11-2011 04:50:16.552 MWPUI Taking ownership of updates.aiu file
10-11-2011 04:50:16.645 MWPUI Attempted to perform an unauthorized operation.
10-11-2011 04:50:16.645 MWPUI at System.Security.AccessControl.Win32.SetSecurityInfo(ResourceType type, String name, SafeHandle handle, SecurityInfos securityInformation, SecurityIdentifier owner, SecurityIdentifier group, GenericAcl sacl, GenericAcl dacl)
at System.Security.AccessControl.NativeObjectSecurity.Persist(String name, SafeHandle handle, AccessControlSections includeSections, Object exceptionContext)
at System.Security.AccessControl.NativeObjectSecurity.Persist(String name, AccessControlSections includeSections, Object exceptionContext)
at System.Security.AccessControl.NativeObjectSecurity.Persist(String name, AccessControlSections includeSections)
at System.Security.AccessControl.FileSystemSecurity.Persist(String fullPath)
at System.IO.File.SetAccessControl(String path, FileSecurity fileSecurity)
at MailWasherPro.Update.TakeOwnershipOfFile(String file)
10-11-2011 04:50:16.677 MWPUI Deleting updates.aiu file
10-11-2011 04:50:16.677 MWPUI Access to the path 'C:\ProgramData\Firetrust\updates\updates.aiu' is denied.
10-11-2011 04:50:16.677 MWPUI at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.File.Delete(String path)
at MailWasherPro.Update.UpdateConfigINI()
10-11-2011 04:50:16.677 MWPUI Running update check
10-11-2011 04:50:43.977 MWPUI Manually checking for updates

I would change the folder MailWasher uses and see how that goes, it's going to work the first time, but it's the next update that will be the test. Either use the same folder found under Help >> User Files >> or just create your own.
User avatar
Duck
Active Albatross
Posts: 189
Joined: Thu Jul 08, 2010 4:07 am

Re: Old Update Bug

Wed Oct 12, 2011 7:52 am

rusticdog wrote:I would change the folder MailWasher uses and see how that goes, it's going to work the first time, but it's the next update that will be the test. Either use the same folder found under Help >> User Files >> or just create your own.
Thanks RD for the quick response. I will follow your suggestion but before I do, do you think it would make any difference if I just did a clean install? I'm talking about backing up the folders and just doing a complete uninstall and reinstall?

Duck

P.S. Does she have a sister? I need one of those! :bow

Return to “MailWasher Pro 7”