7.11.10 Crashing

Forum for MailWasher Pro 7 and/or older 2011/2012 versions.
heimdal
Mystified Moa
Posts: 6
Joined: Tue Aug 01, 2017 11:29 pm

7.11.10 Crashing

Mon Dec 31, 2018 1:00 am

I have just installed mailwasher onto my PC after a hard-disk recovery.

Before the recovery, I would open mailwasher pro and it would stay open until I closed it. After I installed on my new disk and re-authorised it. Now it only stays open for a few minutes, before it closes down without an error and I have to restart it.

I have also been getting a new yahoo prompt, which support are looking into, so I don't know it this is causing the issue.

Thanks Luke
heimdal
Mystified Moa
Posts: 6
Joined: Tue Aug 01, 2017 11:29 pm

Re: 7.11.10 Crashing

Mon Dec 31, 2018 1:15 am

Noticed this in the log:
12-30-2018 13:50:57.656 MWPUI Initiating fetches
12-30-2018 13:50:57.656 MWPUI Error occurred when retrieving fav icon during fetch
12-30-2018 13:50:57.657 MWPUI Access to the path 'C:\ProgramData\Firetrust\MailWasher\ServerList.xml' is denied.
12-30-2018 13:50:57.659 MWPUI at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)
at System.IO.FileStream..ctor(String path, FileMode mode)
at MailWasherPro.MWPMainWindow.RetrieveFavIconsThread(Object o)
12-30-2018 13:50:57.697 MWPUI Stored position = 485,145
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 14039
Joined: Mon Jun 13, 2005 6:27 pm

Re: 7.11.10 Crashing

Mon Dec 31, 2018 2:31 am

That's OK, that error is benign.

Can you try this version
http://cdn.firetrust.com/downloads/mail ... _11_15.exe

It will install fine over the top, and does have a fix related to Yahoo OAUTH that I think might be the issue here.
You can also try disabling OAUTH, under Settings >> Accounts >> Incoming >> Advanced. Uncheck this for the Yahoo account.
heimdal
Mystified Moa
Posts: 6
Joined: Tue Aug 01, 2017 11:29 pm

Re: 7.11.10 Crashing

Sat Jan 12, 2019 3:43 pm

I tried the new install and it had the same issue. However I removed the OAUTH setting and it worked a charm. Thanks for you help

Return to “MailWasher Pro 7”