Stopped connecting on Yahoo

Forum for MailWasher Pro 7 and/or older 2011/2012 versions.
HikariWS
Student Sheep
Posts: 18
Joined: Mon May 25, 2020 3:03 am

Stopped connecting on Yahoo

Tue Mar 16, 2021 2:57 am

Did anything happen?

I have 2 Yahoo accounts set on MailWasher, and a few weeks ago it stopped connecting on them.

I hadn't changed anything, it took a few days to notice the issue then I remade the settings for 1 of them while keeping the other unchanged and am unable to make it connect.

Log doesn't bring anything useful:

Code: Select all

Description: Failed to login to server "pop.mail.yahoo.com.br" for your yahoo - ||||| account

Diagnosis: 

This could suggest the following problems:

	- Your username or password is incorrect.
- The server address is incorrect.
- You are trying to connect through an invalid port.
I'm able to login on webmail normally. Current POP3 settings:

server: pop.mail.yahoo.com.br
username: yahoo login without @
Store cached emails: checked
port: 995
Server requres SSL: checked
Use secure authentication: checked
Use RETR instead of TOP: unchecked (what is this option?)
Enable Pipelining for checking email: checked (what is this option?)
Enable Pipelining for deleting email: checked
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 15426
Joined: Mon Jun 13, 2005 6:27 pm

Re: Stopped connecting on Yahoo

Tue Mar 16, 2021 3:10 am

Try changing your username to your full Yahoo email address, and set the Incoming server to pop.mail.yahoo.com

This should then display the option to Use OAUTH under the Advanced settings in the Incoming screen. Check this and try checking the account, you'll get a popup where you need to logon and give MailWasher to access the account using the OAUTH system.
HikariWS
Student Sheep
Posts: 18
Joined: Mon May 25, 2020 3:03 am

Re: Stopped connecting on Yahoo

Tue Mar 16, 2021 3:47 am

Tnx. OAUTH option appeared, but it failed test and check. No popup appeared.
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 15426
Joined: Mon Jun 13, 2005 6:27 pm

Re: Stopped connecting on Yahoo

Tue Mar 16, 2021 12:26 pm

HikariWS wrote:
Tue Mar 16, 2021 3:47 am
Tnx. OAUTH option appeared, but it failed test and check. No popup appeared.
OK, try going into Help >> User Files >> open the cache folder >> look for a file called youremailaddress@yahoo.com_token >> delete this file >> restart MailWasher. See if it then works using the OAUTH and displays the popup.
HikariWS
Student Sheep
Posts: 18
Joined: Mon May 25, 2020 3:03 am

Re: Stopped connecting on Yahoo

Tue Mar 16, 2021 1:49 pm

There's no file on cache folder with any of my emails. All files start with mwp and there's a crypto folder...
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 15426
Joined: Mon Jun 13, 2005 6:27 pm

Re: Stopped connecting on Yahoo

Tue Mar 16, 2021 2:59 pm

OK, that's odd.
If you set the OAUTH option >> Save >> let it fail >> then click the Inbox tab in MailWasher and answer Yes to save your account changes >> then do a Check Mail >> does the popup then appear ?
HikariWS
Student Sheep
Posts: 18
Joined: Mon May 25, 2020 3:03 am

Re: Stopped connecting on Yahoo

Tue Mar 16, 2021 4:20 pm

Here's the steps:
1) went to Settings > account and saved with OAUTH checked
2) Tested server connection, failed
3) went Inbox > Check > checked the account
4) logging to yahoo

it ended without connecting and there's no popup
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 15426
Joined: Mon Jun 13, 2005 6:27 pm

Re: Stopped connecting on Yahoo

Tue Mar 16, 2021 4:22 pm

HikariWS wrote:
Tue Mar 16, 2021 4:20 pm
Here's the steps:
1) went to Settings > account and saved with OAUTH checked
2) Tested server connection, failed
3) went Inbox > Check > checked the account
4) logging to yahoo

it ended without connecting and there's no popup
OK, can you try sending me logs.
Go Help >> Send Support Logs >> enter a note like 'as per forum - yahoo' >> in the Ticket number field enter chris >> Send Logs >> reply back once sent, so I can confirm if they arrived all OK.

Thanks
HikariWS
Student Sheep
Posts: 18
Joined: Mon May 25, 2020 3:03 am

Re: Stopped connecting on Yahoo

Tue Mar 16, 2021 4:33 pm

ok sent
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 15426
Joined: Mon Jun 13, 2005 6:27 pm

Re: Stopped connecting on Yahoo

Tue Mar 16, 2021 4:49 pm

Great, thanks.

Try first setting the username to be the full Yahoo email address, check the OAUTH option >> Save.

Below is an example of my test account for Yahoo Australia, I assume Yahoo Brazil is the same.

The other option is go to https://login.yahoo.com/account/security or possibly https://login.yahoo.com.br/account/security and down the very bottom there is an option to generate an App Password. If you created an App Password to use in MailWasher, that should also work and does not need the OAUTH option.

When using OAUTH : your regular Yahoo password
When not using OAUTH : use an App Password
yahoo.png
yahoo.png (44.48 KiB) Viewed 244 times
HikariWS
Student Sheep
Posts: 18
Joined: Mon May 25, 2020 3:03 am

Re: Stopped connecting on Yahoo

Tue Mar 16, 2021 7:18 pm

It worked now :)

I never had to do this OAUTH. It wasn't available because previously I had to use pop domain from the country of the account. While I was trying to make it work I guess I removed the domain from login and didn't put it back.

Return to “MailWasher Pro 7”