MailWasher Android version, testing results

MailWasher Mobile for IOS (iPhone, iPod touch, iPad), Android devices and Windows Phone 8.
User avatar
diogenes
Active Albatross
Contact:
Location: Williamstown, Massachusetts, USA
Posts: 104
Joined: Fri Oct 30, 2009 10:53 am

Re: MailWasher Android version, testing results

Fri Oct 19, 2012 12:05 pm

Android Galaxy Nexus.

Message summary not fully displayed when message in the list window was at the bottom of the display.

When there are enough emails to fill the screen in the compact listing, scroll to the bottom.
Click on the last message listing.
It expands in the same space as the compact listing used leaving the additional text and the option buttons hidden below the screen. It should automatically scroll the screen so that the entire new window is displayed This also happens for the bottom listing even when you are not at the end of the list. Both cases (same problem) require the user to manually scroll the screen in order to see the whole of the newly opened summary window. To save extra finger strokes (and thus make the interface more ergonomically friendly) the newly opened window must display as much as it can fit on the display up to the limit of the display, scrolling as necessary. (This would not be an issue if my earlier suggestion is adopted.)
--
Ralph E Kenyon Jr - Philosopher
Retired Navy, former IT consultant and programmer, now retired.
http://www.xenodochy.org
User avatar
nick.bolton
The Big Cheese
Posts: 2111
Joined: Thu Aug 28, 2008 4:02 pm

Re: MailWasher Android version, testing results

Fri Oct 19, 2012 12:25 pm

Thanks, yes we noticed this the other day and will get it fixed.
User avatar
jahnr
Student Sheep
Location: Wien
Posts: 16
Joined: Wed Jun 20, 2012 7:18 am

Re: MailWasher Android version, testing results

Fri Oct 19, 2012 7:24 pm

Hi,

when starting the MW APP I get a blue screen, showing me any (last used?) EMail account on the up/left corner, nothin in the body of he page.
Pushing this button I get the list of my defined EMail accounts.

Some of them have an orange square with a red number, but NO incoming mail is outstanding.
It this, maybe a number of mails in the trash? A trash-handling is curently not offered.
thanks in advance / Danke
Robert
Mailwasher Pro [v7.1.0] ― Mailwasher Mobile [v1.2]
User avatar
nick.bolton
The Big Cheese
Posts: 2111
Joined: Thu Aug 28, 2008 4:02 pm

Re: MailWasher Android version, testing results

Fri Oct 19, 2012 7:34 pm

@jahnr - There's no trash system yet, but if you see orange numbers that would indicate the number of new emails since last checked. So, you're not seeing these emails displayed?
User avatar
jahnr
Student Sheep
Location: Wien
Posts: 16
Joined: Wed Jun 20, 2012 7:18 am

Re: MailWasher Android version, testing results

Fri Oct 19, 2012 9:39 pm

@nick

they are not displayed, maybe that I have washed them from PC MW Pro, so I was not missing any mail
but was astonishsed to see the number.
thanks in advance / Danke
Robert
Mailwasher Pro [v7.1.0] ― Mailwasher Mobile [v1.2]
User avatar
nick.bolton
The Big Cheese
Posts: 2111
Joined: Thu Aug 28, 2008 4:02 pm

Re: MailWasher Android version, testing results

Fri Oct 19, 2012 9:58 pm

Thanks, we'll look in to that. It might just be a timing issue, MW mobile showing the number from last check when there were emails on the server.r
User avatar
diogenes
Active Albatross
Contact:
Location: Williamstown, Massachusetts, USA
Posts: 104
Joined: Fri Oct 30, 2009 10:53 am

Re: MailWasher Android version, testing results

Wed Oct 31, 2012 9:15 am

I've noticed these large red numbers on the email accounts when I open the app and go to the list of accounts. Most of the time the number of emails that actually show up when I open the email account is much less than the number displayed or none at all. I suspect that the system is counting new emails when they are discovered, but not subtracting from the count when the emails are deleted by other email programs. This would be part of the process of discovering that a previously registered email was no longer on the mail server. The emails are deleted, but the count is not decremented -- until the user selects the account, then the number goes to zero to start over.

This can be tested by sending yourself an email while mailwasher mobile is inactive, allowing time for the mailwasher to register the email, then deleting the email from the server via means outside of mailwasher. Then when you open mailwasher and select the accounts list, you should see the number 1 on the account, but when you select the account, the message you sent and deleted is not there. You'll need to make sure mailwasher is not selected to the account when you exit prior to the test.
--
Ralph E Kenyon Jr - Philosopher
Retired Navy, former IT consultant and programmer, now retired.
http://www.xenodochy.org
User avatar
nick.bolton
The Big Cheese
Posts: 2111
Joined: Thu Aug 28, 2008 4:02 pm

Re: MailWasher Android version, testing results

Wed Oct 31, 2012 1:13 pm

That's true, we'll look in to fixing this up.
User avatar
SSTSylvain
Modérateur française
Posts: 295
Joined: Tue Jun 30, 2009 2:44 am

Re: MailWasher Android version, testing results

Wed Oct 31, 2012 6:51 pm

MailWasher Android v0.05
ok we'll change the requirement from 4 characters to 2 or 3 in the next release :)
MailWasher Android v0.06, same problem = it have the 4 characters minimum username. :help then i cant use the MailWasher Android v0.05 - v0.06 software.
SSTSylvain
Moderator, Translator, Beta Testor
User avatar
jahnr
Student Sheep
Location: Wien
Posts: 16
Joined: Wed Jun 20, 2012 7:18 am

Re: MailWasher Android version, testing results

Wed Oct 31, 2012 8:53 pm

Hi,

have installed MW V0.6 - user/password is not accepted neither on mobile nor on the browser version.
thanks in advance / Danke
Robert
Mailwasher Pro [v7.1.0] ― Mailwasher Mobile [v1.2]
User avatar
nick.bolton
The Big Cheese
Posts: 2111
Joined: Thu Aug 28, 2008 4:02 pm

Re: MailWasher Android version, testing results

Wed Oct 31, 2012 9:08 pm

You'll need to setup a new MailWasher ID. We had to clear the old database out because we made many changes, so just create a new Mailwasher ID (User/pass)
User avatar
diogenes
Active Albatross
Contact:
Location: Williamstown, Massachusetts, USA
Posts: 104
Joined: Fri Oct 30, 2009 10:53 am

Re: MailWasher Android version, testing results

Thu Nov 22, 2012 7:50 am

Android Galaxy Nexus with Jelly Bean 4.1.1 -
I have 25 emails in one of my accounts now. When I try to read a message, I get no response. I can click on the buttons on the top of the screen and tools and email selector both work. (I have not yet tried wash.) I can change to other accounts with fewer emails, and they all respond. Some of the emails have been marked green as good, some have been marked pink as blocked. I can toggle the trash check-box on each message, but reading a mail is unresponsive.
I think it "thinks" it has no display space left.

Now I pressed wash. It deleted 5 messages. Now I have 20 messages on the screen that won't open. It apparently did not update "screen full" flag if you have one, or the count of messages displayed, or there is some other place not updated by wash that would have allowed unlocking the message display (which should not have been locked in the first place).

I exited this account, saw the count box in red saying I had 1 new message, and re-entered the display. Same lock-up, but now there is again 25 messages.

This time I exited my account, and tried another account, one with only 4 messages. It's locked now too. In fact, they are all locked now.

Tried logging out and logging back in. Did not help.
--
Ralph E Kenyon Jr - Philosopher
Retired Navy, former IT consultant and programmer, now retired.
http://www.xenodochy.org
User avatar
nick.bolton
The Big Cheese
Posts: 2111
Joined: Thu Aug 28, 2008 4:02 pm

Re: MailWasher Android version, testing results

Thu Nov 22, 2012 7:59 am

Does this happen on http://node.mailwasher.me ?

Our host got DDos'd yesterday on and off, but all seems ok now
User avatar
diogenes
Active Albatross
Contact:
Location: Williamstown, Massachusetts, USA
Posts: 104
Joined: Fri Oct 30, 2009 10:53 am

Re: MailWasher Android version, testing results

Thu Nov 22, 2012 9:29 am

nick.bolton wrote:Does this happen on http://node.mailwasher.me ?

Our host got DDos'd yesterday on and off, but all seems ok now
The two systems behave differently.
On line, clicking on a message with the mouse allows it to be displayed, but clicking on the back button results in an error sometimes.
Sometimes the screen remains blank.
Reload brings back the message list.
Neither is working correctly, but they fail in different ways.
I'm going to run my MW 6.5.4 and get rid of the spam, and see if that allows the system to restore.
--
Ralph E Kenyon Jr - Philosopher
Retired Navy, former IT consultant and programmer, now retired.
http://www.xenodochy.org
User avatar
diogenes
Active Albatross
Contact:
Location: Williamstown, Massachusetts, USA
Posts: 104
Joined: Fri Oct 30, 2009 10:53 am

Re: MailWasher Android version, testing results

Thu Nov 22, 2012 11:30 am

After manually syncing with 6.5.4 - getting rid of all spam and downloading all mail, the system seemed to return to normal.
The next login allowed reading per normal.
--
Ralph E Kenyon Jr - Philosopher
Retired Navy, former IT consultant and programmer, now retired.
http://www.xenodochy.org

Return to “Mobile for IOS/Android/Windows Phone 8”