3.0 Install Fail

watsonm
Student Sheep
Posts: 17
Joined: Fri Mar 18, 2016 5:05 am

3.0 Install Fail

Postby watsonm Thu Mar 30, 2017 5:18 am

Been trying to Install 3.0.1 (and 3.0.0) and constantly get a failure of the driver install code.

Have uninstalled previous version and rebooted umpteen times.
Tried running installer as administrator still no luck

Driver install failed 4294967295 message Command Failed

C:\\ users....... \app-3.0.1\resour..\HideAwayDriverSetup.exe --install

Thanks for any help


Windows 10 64bit
User avatar
TrustFire
βeta Tester
Posts: 12335
Joined: Fri Jul 30, 2010 11:04 pm
Location: 127.0.0.1

Re: 3.0 Install Fail

Postby TrustFire Thu Mar 30, 2017 5:25 am

What happens if you try installing in Safe Mode?
MWP 7 disabled from the cloud (ßeta) | Windows 8.1 Pro (x64) | The Bat! Professional (ßeta) | Windows Firewall Control (WFC) | NOD32 EAV (ßeta) | Intel® HD Graphics 3000 | Internet Connection Speed (D=50 Mb/s U=3.5 Mb/s) | .NET Framework (4.7.1)
watsonm
Student Sheep
Posts: 17
Joined: Fri Mar 18, 2016 5:05 am

Re: 3.0 Install Fail

Postby watsonm Thu Mar 30, 2017 6:45 am

TrustFire wrote:What happens if you try installing in Safe Mode?


It doesn't even attempt to install.

Few seconds of "working circle" and then silence!
watsonm
Student Sheep
Posts: 17
Joined: Fri Mar 18, 2016 5:05 am

Re: 3.0 Install Fail

Postby watsonm Thu Mar 30, 2017 6:53 am

Not sure if it's relevant but in the drivers directory there is just the exe file and no driver file.
(ie one I recognize as a driver .sys .inf ) unless it is embedded in the exe
User avatar
TrustFire
βeta Tester
Posts: 12335
Joined: Fri Jul 30, 2010 11:04 pm
Location: 127.0.0.1

Re: 3.0 Install Fail

Postby TrustFire Thu Mar 30, 2017 8:14 am

Are you able to run the program by double clicking HideAway.exe which (in your case) might reside at either of the following directories:—

    Code: Select all

    C:\Users\YourUserName\AppData\Local\HideAway\app-3.0.1

    Code: Select all

    C:\Users\YourUserName\AppData\Local\HideAway\app-3.0.0
MWP 7 disabled from the cloud (ßeta) | Windows 8.1 Pro (x64) | The Bat! Professional (ßeta) | Windows Firewall Control (WFC) | NOD32 EAV (ßeta) | Intel® HD Graphics 3000 | Internet Connection Speed (D=50 Mb/s U=3.5 Mb/s) | .NET Framework (4.7.1)
User avatar
nick.bolton
The Big Cheese
Posts: 1627
Joined: Thu Aug 28, 2008 4:02 pm

Re: 3.0 Install Fail

Postby nick.bolton Thu Mar 30, 2017 11:57 am

Hi, can you please try this

1. Command Prompt (Run as Administrator)
2. `cd %LOCALAPPDATA%\HideAway\app-3.0.1\resources\driver`
3. `HideAwayDriverSetup.exe -u` (to uninstall, will need restart)

Then run HideAway clicking "Yes" if UAC is On.

If that still fails, repeat Step 1 and 2 but instead type:
`HideAwayDriverSetup.exe -i` (to install, and screenshot please)
FransL
Rattled Rabbit
Posts: 2
Joined: Sun Oct 12, 2008 11:30 pm

Re: 3.0 Install Fail

Postby FransL Thu Mar 30, 2017 10:20 pm

watsonm wrote:Been trying to Install 3.0.1 (and 3.0.0) and constantly get a failure of the driver install code.


Same here

IMHO it is a programming error when the installation path contains 'spaces'.
Spaces are not handeled correctly and HideAway installs with a 'non existing' path.
watsonm
Student Sheep
Posts: 17
Joined: Fri Mar 18, 2016 5:05 am

Re: 3.0 Install Fail

Postby watsonm Fri Mar 31, 2017 12:03 am

TrustFire wrote:Are you able to run the program by double clicking HideAway.exe which (in your case) might reside at either of the following directories:—

    Code: Select all

    C:\Users\YourUserName\AppData\Local\HideAway\app-3.0.1

    Code: Select all

    C:\Users\YourUserName\AppData\Local\HideAway\app-3.0.0



That produces the same error with an extra line...

registerDriverr (-1) unknown error
watsonm
Student Sheep
Posts: 17
Joined: Fri Mar 18, 2016 5:05 am

Re: 3.0 Install Fail

Postby watsonm Fri Mar 31, 2017 12:16 am

nick.bolton wrote:Hi, can you please try this

1. Command Prompt (Run as Administrator)
2. `cd %LOCALAPPDATA%\HideAway\app-3.0.1\resources\driver`
3. `HideAwayDriverSetup.exe -u` (to uninstall, will need restart)

Then run HideAway clicking "Yes" if UAC is On.

If that still fails, repeat Step 1 and 2 but instead type:
`HideAwayDriverSetup.exe -i` (to install, and screenshot please)



Now that surprised me.
I did the uninstall and reboot.
Then I thought why is he asking me to click on Hiedaway if I have just uninstalled it!!

But doing so and 3.0.1 worked!!!!!!!!


Many thanks for your help
smart1960
βeta Tester
Posts: 251
Joined: Fri Jul 25, 2008 4:56 am

Re: 3.0 Install Fail

Postby smart1960 Fri Mar 31, 2017 6:18 am

Have you tried running this as "ADMINISTRATOR"? I had this problem and after the fix sent by Chris ran as ADMIN and it did what it should do. :D :D
watsonm
Student Sheep
Posts: 17
Joined: Fri Mar 18, 2016 5:05 am

Re: 3.0 Install Fail

Postby watsonm Fri Mar 31, 2017 7:19 am

smart1960 wrote:Have you tried running this as "ADMINISTRATOR"? I had this problem and after the fix sent by Chris ran as ADMIN and it did what it should do. :D :D


Cheers, I believe i said I tried that in the original post .

Fortunately Nick's post fixed the issue.
FrancesBur
It begins with a single step
Posts: 1
Joined: Fri Oct 06, 2017 4:34 am

Re: 3.0 Install Fail

Postby FrancesBur Thu Oct 12, 2017 2:21 am

smart1960 wrote:Have you tried running this as "ADMINISTRATOR"? I had this problem and after the fix sent by Chris ran as ADMIN and it did what it should do. :D :D


When I right click on it there is no run as admin button. How do you run as admin?
User avatar
nick.bolton
The Big Cheese
Posts: 1627
Joined: Thu Aug 28, 2008 4:02 pm

Re: 3.0 Install Fail

Postby nick.bolton Thu Oct 12, 2017 7:54 am

Just right click on the file, a menu will pop up, choose 'Run as administrator'
User avatar
TrustFire
βeta Tester
Posts: 12335
Joined: Fri Jul 30, 2010 11:04 pm
Location: 127.0.0.1

Re: 3.0 Install Fail

Postby TrustFire Thu Oct 12, 2017 10:51 am

In case your Run as administrator context menu is truly missing, you can restore it by downloading and then merging the following entry into your registry (by just running it):—

MWP 7 disabled from the cloud (ßeta) | Windows 8.1 Pro (x64) | The Bat! Professional (ßeta) | Windows Firewall Control (WFC) | NOD32 EAV (ßeta) | Intel® HD Graphics 3000 | Internet Connection Speed (D=50 Mb/s U=3.5 Mb/s) | .NET Framework (4.7.1)

Return to “HideAway”

Who is online

Users browsing this forum: No registered users and 1 guest