HA 4 Local Printer not working

User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 14121
Joined: Mon Jun 13, 2005 6:27 pm

Re: HA 4 Local Printer not working

Wed Jul 31, 2019 10:08 pm

A long shot, but also worth trying restarting the printer spooler service after starting HA.

To do that, open CMD as Admin https://www.howtogeek.com/194041/how-to ... ndows-8.1/

Then type
net stop spooler
Hit Enter, wait for service to stop

Then type
net start spooler
hit Enter

Set if HA can print then.


Could you also post a screenshot of your printer set, if you right go into Printer services, right click the printer >> Properties >> select the Ports tab >> select Configure Port >> grab a screenshot of those settings >> Cancel
Andrew42
Active Albatross
Posts: 191
Joined: Thu Jul 15, 2010 2:43 am

Re: HA 4 Local Printer not working

Wed Jul 31, 2019 11:42 pm

Did as you asked, nothing printed until I stopped HA.

Attached are three screen shot covering the Ports setting for the HP Envy that I am using today,
Envy Printer 1.jpg
Envy Printer 1.jpg (251.19 KiB) Viewed 162 times
Envy Printer 2.jpg
Envy Printer 2.jpg (265.65 KiB) Viewed 162 times
Envy Printer 3.jpg
Envy Printer 3.jpg (254.93 KiB) Viewed 162 times
Andrew42
Active Albatross
Posts: 191
Joined: Thu Jul 15, 2010 2:43 am

Re: HA 4 Local Printer not working

Wed Aug 07, 2019 7:38 pm

Today I HA upgraded to V4.1.4 so I tried to print. No go, (printer off-line), but even worse, stopping HA no longer re-establishes connections to the printer, I have to reboot to get my queue to print.
User avatar
nick.bolton
The Big Cheese
Posts: 1888
Joined: Thu Aug 28, 2008 4:02 pm

Re: HA 4 Local Printer not working

Wed Aug 07, 2019 7:44 pm

That's frustrating for sure as it didn't contain any changes related to that. Want to try this unreleased version
http://cdn.firetrust.com/downloads/hide ... -setup.exe

It has a few fixes, but it might not fix the printer issue, but would be interesting to see all the same.
Andrew42
Active Albatross
Posts: 191
Joined: Thu Jul 15, 2010 2:43 am

Re: HA 4 Local Printer not working

Wed Aug 07, 2019 8:50 pm

I installed the new version: no change fro 4.1.4 have to reboot for the printer to come back on line.

I installed the new version over the top of 4.1.4. Might there be any value in my trying a clean installation? If so please advise how remove all references to HA if simply uninstalling the programme is not enough.
User avatar
nick.bolton
The Big Cheese
Posts: 1888
Joined: Thu Aug 28, 2008 4:02 pm

Re: HA 4 Local Printer not working

Wed Aug 07, 2019 9:10 pm

Ok, it's odd because we only added some new locations in that build 4.1.4

If you uninstall HideAway, then restart your computer it will remove absolutely everything.
Andrew42
Active Albatross
Posts: 191
Joined: Thu Jul 15, 2010 2:43 am

Re: HA 4 Local Printer not working

Wed Aug 07, 2019 10:05 pm

Done. No change I’m sorry to write.
Andrew42
Active Albatross
Posts: 191
Joined: Thu Jul 15, 2010 2:43 am

Re: HA 4 Local Printer not working

Mon Aug 12, 2019 9:26 pm

Installed 4.2.1: no change.
User avatar
nick.bolton
The Big Cheese
Posts: 1888
Joined: Thu Aug 28, 2008 4:02 pm

Re: HA 4 Local Printer not working

Mon Aug 12, 2019 9:57 pm

Yes, we've not worked on the printer issue in these last releases - but we've fixed all the last bugs reported, so we're back on to the printer one. Hopefuly can replicate and sort out asap
Andrew42
Active Albatross
Posts: 191
Joined: Thu Jul 15, 2010 2:43 am

Re: HA 4 Local Printer not working

Mon Aug 12, 2019 10:09 pm

Thanks for the update. Until it’s fixed I simply only use HA when I need to as opposed to running it automatically all the time. So, while a nuisance, it is totally manageable.
User avatar
nick.bolton
The Big Cheese
Posts: 1888
Joined: Thu Aug 28, 2008 4:02 pm

Re: HA 4 Local Printer not working

Wed Aug 14, 2019 9:35 pm

Ok, give this a try with 'All Computer' and see if it works.

http://cdn.firetrust.com/downloads/hide ... -setup.exe
Andrew42
Active Albatross
Posts: 191
Joined: Thu Jul 15, 2010 2:43 am

Re: HA 4 Local Printer not working

Thu Aug 15, 2019 3:44 am

Nick, that has worked perfectly on this HP Envy. I have printed with HA diverting to two different countries and also with HA stopped. I also had a Windows update to install so I ran the same tests again successfully after that. Tomorrow I will be at my main computer and will check again and get back to you.
Thank you for taking the trouble to clear this up. I'm grateful.
User avatar
nick.bolton
The Big Cheese
Posts: 1888
Joined: Thu Aug 28, 2008 4:02 pm

Re: HA 4 Local Printer not working

Thu Aug 15, 2019 7:44 am

Great, that's excellent news. I managed to replicate it on one of my kids computers :) Then it was a matter of digging in to the issue.
Here's the gory details.
Apparently the problem occurs because of merging of small outgoing TCP data packets to larger chunks. It is allowed according to the TCP standard. But some printers and other devices built for local networks can contain bugs in their software, and merging packets may break the parsing of transmitted data on their side.
So we added a rule to ignore the printer spooler service.
Andrew42
Active Albatross
Posts: 191
Joined: Thu Jul 15, 2010 2:43 am

Re: HA 4 Local Printer not working

Fri Aug 16, 2019 4:42 am

Back home and hooked up to my other HP Printer. Everything is working just as it should. Thanks, Nick, again. If I understood correctly what you wrote it would appear HP have a problem in their software which you identified and simply circumvented: clever.
User avatar
nick.bolton
The Big Cheese
Posts: 1888
Joined: Thu Aug 28, 2008 4:02 pm

Re: HA 4 Local Printer not working

Fri Aug 16, 2019 9:00 pm

Thanks for conforming it all works there too. Now on to the rest of the features :)

Return to “HideAway”