HA drops internet speed down to about a tenth

ctvmh
Student Sheep
Posts: 10
Joined: Wed Jun 03, 2015 1:05 am

HA drops internet speed down to about a tenth

Wed Jun 03, 2015 3:04 am

I'm Running Naked DSL with iinet.
When I do speed tests with HA turned on speed via speedtest.net is very poor indeed from about 10Mbps without HA to 1.2Mbps the ping test delay is scary. Upload almost no existent with HA. Any Ideas how to improve?

I'm using Windows 8.1 Professional 64bit with both IE 11 and Chrome installed (Chrome my preferred browser).
HA version 1.2.0

My corporate vpn runs faster than HA on another identical machine which is also DEll XPS 17.

HA on 6/2/2015 2:44 PM GMT 168.1.109.54 1.22 Mb/s 0.09 Mb/s 280 ms Melbourne < 50 km
HA off 6/2/2015 2:37 PM GMT 106.68.23.145 9.85 Mb/s 0.50 Mb/s 59 ms Melbourne ~ 2700 km
HA on 6/2/2015 2:35 PM GMT 168.1.109.54 1.07 Mb/s 0.10 Mb/s 281 ms Melbourne < 50 km
HA off 5/31/2015 2:57 AM GMT 124.148.246.214 9.97 Mb/s 0.40 Mb/s 18 ms Perth < 50 km

Rebooted router to check but still same speed issues with HA on.

Any way to tweak?
Regards
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 14278
Joined: Mon Jun 13, 2005 6:27 pm

Re: HA drops internet speed down to about a tenth

Wed Jun 03, 2015 3:45 pm

Which country/server are you selecting when testing ?
ctvmh
Student Sheep
Posts: 10
Joined: Wed Jun 03, 2015 1:05 am

Re: HA drops internet speed down to about a tenth

Wed Jun 03, 2015 7:26 pm

Hi Speedtest.net selects what it thinks is the best server automatically.
It appears that HA locates another server through Melbourne. I'm in Perth so it is interesting that with HA off speedtest.net server it pings and tests is 27000kms away. Yet when HA is on it reports a similar server ip is only about 50kms away.
I have speed test results that go back over years it appears that HA seems to change the speed test locates servers for test weather it is on or off. There might be something in the chrome cache that is planted by HA?
Histrionically I have had speed tests that go through iinet or Telstra servers located in Perth.
Last edited by ctvmh on Wed Jun 03, 2015 7:28 pm, edited 1 time in total.
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 14278
Joined: Mon Jun 13, 2005 6:27 pm

Re: HA drops internet speed down to about a tenth

Wed Jun 03, 2015 7:58 pm

Yeah that’s pretty weird. Wonder if the speed test is with the same server.


To do a consistent speed test, load up a browser rule in HideAway like chrome.exe to redirect to one of the servers through Hideaway.

Go to http://www.speedtest.net, and start the test - do it 3 times for consistency. ,

Next, disable the chrome rule in Hideaway and do the exact same test (‘Test Again’ button) so traffic is not going through Hideaway but is using the same test server. Do this 3 times for consistency.


We do have some optimizations to do on the server side, but the guys have had a look at the connections on the aus server and there’s not much happening on it.
ctvmh
Student Sheep
Posts: 10
Joined: Wed Jun 03, 2015 1:05 am

Re: HA drops internet speed down to about a tenth

Sat Jun 06, 2015 2:51 am

Thanks for your suggestions rusticdog.
I tried the tests as recommended. With HA loaded and operated with chrome rule a slight improvement in download speed but still HA seems to redirect speedtest.net to a Melbourne sever rather than a Perth based server which is closer and pings better and downloads and faster.

The three tests with the HA chrome.exe rule loaded speedtest.net reported:( Far two slow for me)

6/5/2015 2:32 PM GMT 168.1.109.54 1.35 Mb/s 0.32 Mb/s 110 ms Perth ~ 2700 km
6/5/2015 2:30 PM GMT 168.1.109.54 1.71 Mb/s 0.30 Mb/s 111 ms Perth ~ 2700 km
6/5/2015 2:28 PM GMT 168.1.109.54 1.99 Mb/s 0.28 Mb/s 114 ms Perth ~ 2700 km
6/5/2015 2:21 PM GMT 168.1.109.54 1.64 Mb/s 0.36 Mb/s 122 ms Perth ~ 2700 km

Is 168.1.109.54 a firetrust HA sever in Melbourne?

I'm not sure why but the same slow down is true with either IE, FireFox and chrome browsers.
Speedtest.net are fine if I don't use HA and the Speedtest.net application locates the iinet server( my service provider) and then speedtest results trumps the HA application.

Do you have a server in Perth that HA can work through? As HA seems to force the test server to default to run through Melbounre which is about 2700kms away.

Any suggestions?

Regards
ctvmh
Student Sheep
Posts: 10
Joined: Wed Jun 03, 2015 1:05 am

Re: HA drops internet speed down to about a tenth

Sat Jun 06, 2015 3:19 am

This is interesting in my view I just deleted the HA DNS rule form the active rule list and speedtestnet reported a increase in download speed to about 5mbps... could each HA rule act as a HA internet speed reduction multiplier?
What do you think? BBC is still extremely slow to respond with HA rules active.
User avatar
nick.bolton
The Big Cheese
Posts: 1972
Joined: Thu Aug 28, 2008 4:02 pm

Re: HA drops internet speed down to about a tenth

Sat Jun 06, 2015 12:49 pm

Sorry, we don't have a Perth server, and yes our server is in Melbourne so it's very far away and perhaps the routing is not the best there is from Perth. There's so many things which can affect speed such as distance, routers, other servers. We know we need to improve on the reliability with some optimizations to the protocol as you could be experiencing packet loss, so that's something we're working on and that could be all the difference.

@ctvmh - Surprised about turning off the DNS rule, but it does mean that all the applications which are used as svchost.exe are redirected through that connection too. I think the same applies to you with BBC, we clearly need to work on some optimizations because some of the packets are not reliably coming back or there's jitter. It's a big priority for us and we hope to have an update soon.
ctvmh
Student Sheep
Posts: 10
Joined: Wed Jun 03, 2015 1:05 am

Re: HA drops internet speed down to about a tenth

Thu Jun 11, 2015 12:38 am

Hello Nick,
Thanks for the reply. Looks like I'm now running version 1.2.2 now but I'm still having download speed issues. bbc iplayer seems to be a little bit better at downloading file content Seems like HA is giving you-tube playback a hiding as well. If if I turn off the HA Google rule that reduces you-tube buffering but streaming is forced back to very low resolution I have turn off HA to get any speed advantages.

Regards
User avatar
nick.bolton
The Big Cheese
Posts: 1972
Joined: Thu Aug 28, 2008 4:02 pm

Re: HA drops internet speed down to about a tenth

Thu Jun 11, 2015 5:45 am

Thanks for letting me know. We know a few users are having these issues so it's a big priority to fix them. Happy to extend the license for people who are not getting optimal use.
ctvmh
Student Sheep
Posts: 10
Joined: Wed Jun 03, 2015 1:05 am

Re: HA drops internet speed down

Wed Mar 02, 2016 3:22 am

Hi Nick,
HA is still very slow turned off chrome rule. HA Version 1.4.0 I'm getting about 6 mbps with HA enabled. Without HA iinet delivers about 18 mbps in speed.
Any solution to this quantum drop in speed when using HA?

Regards
User avatar
nick.bolton
The Big Cheese
Posts: 1972
Joined: Thu Aug 28, 2008 4:02 pm

Re: HA drops internet speed down to about a tenth

Wed Mar 02, 2016 6:51 am

Ok, just checking you're using the same server to test with? If you're using speedtest.net you can select the default sever in the speedtest.net settings page.

We're still working on our new faster version and will have a beta out soon.

Return to “HideAway”