Page 1 of 1

Hideaway 3.0.1 Cant uninstall Driver

Posted: Sat May 06, 2017 4:09 pm
by Tayrad
Ok, today I removed Hideaway 2.0 in the control panel / Programs and Features. I restarted the computer. I attempted to install 3.0.1..... It says it will not install because the driver removal is pending. Please restart. So I did. Again. and again and again. So I went into the Appdata folder - and used the %LOCALAPPDATA%\HideAway\app-3.0.1\resources\driver folder - ran the HideAwayDriverSetup.exe -u

And it errors. "unregisterDriver: (-1) Unknown error."

The driver is v1.0.0

I tried wiping the whole folder (fail). And installing as administrator (fail). I tried installing without my Comodo firewall (fail), Avast antivirus (fail) and both disabled (also fail).

I uninstalled everything to do with hideaway. And attempted to reinstall.... And still it gets back to the same error -
"HideAway Driver setup cannot continue because a restart from a previous uninstallation or update is pending. Please restart your computer."

Pressing OK gives error box: Driver install failed, code: 350 Command failed: "C:\Users\MyUserName\Appdata\Local\HideAway\app-3.0.1\resour...\HideAwayDriverSetup.exe" --install

I'm kind of running out of ideas :)
Got anything I can try?

Re: Hideaway 3.0.1 Cant uninstall Driver

Posted: Sat May 06, 2017 6:37 pm
by TrustFire
Run RegEdit from an elevated command prompt and navigate to the following key:—
  • [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]
If you find a PendingFileRenameOperations key, just rename it to OldPendingFileRenameOperations >>----> reboot the system >>----> retry your 3.0.1 installation.

Re: Hideaway 3.0.1 Cant uninstall Driver

Posted: Sun May 07, 2017 2:56 am
by Tayrad
Ok Done! On reboot, this entry put itself back and the install failed.

So I got back in to Regedit and wiped the entry out. Without rebooting, I ran the install and it went flawlessly.

Thank you!!

Re: Hideaway 3.0.1 Cant uninstall Driver

Posted: Wed Dec 13, 2017 11:04 am
by gestryn
Hello, just in case this thread still interests anyone, I tried the solution that worked for Tayrad and it did not work for me. After several shots in other directions I came across this ... 98292.html which showed that there may be more than just one "session manager" key in the registry, and that any "PendingFileRenameOperations" entry in each one must be removed. I found 3 in my registry, removed them and then HideAway 3.5 (in my case) installed quickly.
All the best!