HideAway 4.9

optodata
Student Sheep
Contact:
Posts: 15
Joined: Fri Jul 09, 2010 10:59 am

Re: HideAway 4.9

Mon Mar 22, 2021 6:26 pm

AVG doesn't show any files in quarantine and shows 0 threat notifications, but I can try uninstalling it and HideAway then reinstall HideAway to be certain. I've attached the log.log file from the previous installation.

EDIT: No joy after uninstalling AVG then doing a clean HideAway install. I've attached the 2nd log from this installation as well.
Attachments
2nd log.log
(1.39 KiB) Downloaded 16 times
log.log
(1.73 KiB) Downloaded 14 times
User avatar
nick.bolton
The Big Cheese
Posts: 2251
Joined: Thu Aug 28, 2008 4:02 pm

Re: HideAway 4.9

Mon Mar 22, 2021 7:12 pm

Thanks, the log file is not showing anything out of the ordinary, and it doesn't sounds like AVG is causing any issues either. Let me ask the developers...
optodata
Student Sheep
Contact:
Posts: 15
Joined: Fri Jul 09, 2010 10:59 am

Re: HideAway 4.9

Tue Mar 23, 2021 12:06 pm

ok. I went back to a system image I'd made on Feb 17 to see if it might have been the update to 4.16.5 that caused the issue, but HideAway didn't run at startup on that image either. I then went back to early Dec 2020 and verified that HideAway launched at startup and updated itself to the current version. I then rebooted and confirmed that 4.16.5 ran on startup as expected, so I've attached that log here.

There have been many system updates in the past 3 months so I've restored my current system image, but if the developers can't figure out what's going on I may go back to 12/2020 and apply all the other updates to see if everything works correctly, or at least find where HideAway stops loading at startup.
Attachments
log.log
update log from running restored 12/2020 system image
(7.59 KiB) Downloaded 13 times
User avatar
nick.bolton
The Big Cheese
Posts: 2251
Joined: Thu Aug 28, 2008 4:02 pm

Re: HideAway 4.9

Tue Mar 23, 2021 12:32 pm

Did you get a screenshot of what you were seeing with this?
optodata
Student Sheep
Contact:
Posts: 15
Joined: Fri Jul 09, 2010 10:59 am

Re: HideAway 4.9

Tue Mar 23, 2021 1:23 pm

nick.bolton wrote:
Tue Mar 23, 2021 12:32 pm
Did you get a screenshot of what you were seeing with this?
No. It was simply the HideAway splash screen with "Checking for Updates" then "Starting" and then it minimized to the tray. During the update, I got the UAC and a new icon was placed on my desktop (I normally don't have one there).

In my current situation, no splash screen appears and there's on HideAway icon in the tray (unless I manually launch the app). These are my current tray contents:

Image
User avatar
nick.bolton
The Big Cheese
Posts: 2251
Joined: Thu Aug 28, 2008 4:02 pm

Re: HideAway 4.9

Tue Mar 23, 2021 1:53 pm

Ok, HideAway will remember the state of it when you shut it down. So if you restart Windows and HideAway was running and connected to London, UK for example, then the next time you start HideAway it will start in that state. If you had it closed when you shut down Windows, it won't auto-start when Windows starts.
Just checking if this was the situation?
optodata
Student Sheep
Contact:
Posts: 15
Joined: Fri Jul 09, 2010 10:59 am

Re: HideAway 4.9

Tue Mar 23, 2021 2:29 pm

Hmm, that doesn't match what I've seen. I only use HA for specific tasks and usually with a specific browser. It's normally disconnected and yet it always started with Windows until recently. I just checked on my Surface Book3 and HA autostarts even though I haven't connected it for months. On my desktop, I left HA in this condition but it still didn't start after I rebooted:

Image

EDIT: When I manually launch HA it does start connected, it's only the autostart that's broken :(

EDIT #2: Also make no difference if I switch to Redirect: My Computer vs. just a specific browser. Still no auto start
User avatar
nick.bolton
The Big Cheese
Posts: 2251
Joined: Thu Aug 28, 2008 4:02 pm

Re: HideAway 4.9

Tue Mar 23, 2021 3:05 pm

I know you mentioned you had seen it in Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
Just checking it looks like this
hideaway start.png
hideaway start.png (2.2 KiB) Viewed 263 times
optodata
Student Sheep
Contact:
Posts: 15
Joined: Fri Jul 09, 2010 10:59 am

Re: HideAway 4.9

Tue Mar 23, 2021 3:27 pm

That's it!

For some reason, installing 4.16.5 from scratch didn't add anything to the registry's Run key, and when I had added something previously I had simply pointed to HA.exe, which was why it ran as an open app. Thanks to your explicit key text, I now have autostart back the way it used to be, with HA checking for an update then dropping to the tray out of sight.

Thanks very much Nick for helping me figure this out! 👍
User avatar
nick.bolton
The Big Cheese
Posts: 2251
Joined: Thu Aug 28, 2008 4:02 pm

Re: HideAway 4.9

Tue Mar 23, 2021 3:51 pm

Excellent, good to hear. I just had a bit of trouble at the start trying to figure out what was happening

Return to “HideAway”