Torrent busted using 4.16.6

AussieRodney
Travelling Tuatara
Location: Seattle
Posts: 39
Joined: Tue Nov 29, 2016 2:13 pm

Torrent busted using 4.16.6

Mon Apr 12, 2021 3:34 pm

After a long period of not receiving nasty messages, I've been busted using BitTorrent through HA 4.16.6 twice in a few weeks.

1. It looks like maybe a recent update didn't carry over the "Run when Windows Starts" mode, so it wasn't running.
I now double check first before torrenting.

2. Using BitTorrent through HA 4.16.6 in "Redirect: Torrent Applications" mode.
Currently set to "Redirect: My Computer".

No damage yet, but don't want to keep pushing my luck.
User avatar
nick.bolton
The Big Cheese
Posts: 2250
Joined: Thu Aug 28, 2008 4:02 pm

Re: Torrent busted using 4.16.6

Mon Apr 12, 2021 5:26 pm

Ok, sorry to hear this.

Do you use a registry cleaner? I wonder if something like this removed the registry key which tells it to start when Windows starts.
AussieRodney
Travelling Tuatara
Location: Seattle
Posts: 39
Joined: Tue Nov 29, 2016 2:13 pm

Re: Torrent busted using 4.16.6

Mon Apr 12, 2021 5:54 pm

Not that I know of.
User avatar
nick.bolton
The Big Cheese
Posts: 2250
Joined: Thu Aug 28, 2008 4:02 pm

Re: Torrent busted using 4.16.6

Mon Apr 12, 2021 8:14 pm

Ok, we'll be releasing a new version this week, please check it starts with Windows.

Actually, it will start in the same state that you left it when you shut down your computer. So if it wasn't connected when you closed HideAway/shut down your computer then it won't start connected.
AussieRodney
Travelling Tuatara
Location: Seattle
Posts: 39
Joined: Tue Nov 29, 2016 2:13 pm

Re: Torrent busted using 4.16.6

Tue Apr 13, 2021 12:28 am

Thanks Nick.
AussieRodney
Travelling Tuatara
Location: Seattle
Posts: 39
Joined: Tue Nov 29, 2016 2:13 pm

Re: Torrent busted using 4.16.6

Thu May 06, 2021 3:34 pm

AussieRodney wrote:
Mon Apr 12, 2021 3:34 pm
Using BitTorrent through HA 4.16.6 in "Redirect: Torrent Applications" mode.
Currently set to "Redirect: My Computer".
Late last week, I had HA set to "Redirect: My Computer" and got busted. Just one infringement, but that's one too many.

Is there a possibility of a leak? Or should I start being extra careful and reboot the laptop & reload HA before I start a download?
User avatar
nick.bolton
The Big Cheese
Posts: 2250
Joined: Thu Aug 28, 2008 4:02 pm

Re: Torrent busted using 4.16.6

Thu May 06, 2021 7:43 pm

Hi, it will redirect your torrents to a torrent friendly location even if you don't have it specifically redirecting to another country.

Do you think it might have been off at one stage before or after downloading a torrent? It should show in the Bittorrent logs the IP address and what was going on at the time.
khanyash
Rattled Rabbit
Posts: 2
Joined: Sun May 02, 2021 9:00 pm

Re: Torrent busted using 4.16.6

Fri May 07, 2021 7:54 am

AussieRodney wrote:
Thu May 06, 2021 3:34 pm
should I start being extra careful and reboot the laptop & reload HA before I start a download?
When you use VPN, it's better to connect the VPN first and then start your browser or application.
AussieRodney
Travelling Tuatara
Location: Seattle
Posts: 39
Joined: Tue Nov 29, 2016 2:13 pm

Re: Torrent busted using 4.16.6

Fri May 07, 2021 3:09 pm

nick.bolton wrote:
Thu May 06, 2021 7:43 pm
Do you think it might have been off at one stage before or after downloading a torrent? It should show in the Bittorrent logs the IP address and what was going on at the time.
khanyash wrote:
Fri May 07, 2021 7:54 am
When you use VPN, it's better to connect the VPN first and then start your browser or application.
These days I am VERY careful about ensuring that HA is running AND is set for "Redirect: My Computer" to Seattle, before even looking at the page that tells me what is available, so that I can grab what I need.

What bothers me from my previous post as well is:
. I was running HA as "Redirect: Torrent Applications" all of the time, in the background.
. Yes, I missed the fact that it wasn't running - my bad.
. After that, I was pretty paranoid about ensuring that HA was running.
. After another hit, I started using HA with "Redirect: My Computer" to Seattle.
. I still got pinged.


. Now, I'm certain that I was using "Redirect: My Computer" to Seattle.
. And I got pinged again.
User avatar
nick.bolton
The Big Cheese
Posts: 2250
Joined: Thu Aug 28, 2008 4:02 pm

Re: Torrent busted using 4.16.6

Fri May 07, 2021 6:21 pm

Which torrent application are you using? Can you get logs from it?
AussieRodney
Travelling Tuatara
Location: Seattle
Posts: 39
Joined: Tue Nov 29, 2016 2:13 pm

Re: Torrent busted using 4.16.6

Sat May 08, 2021 11:06 am

Using uTorrent. Not sure whether they have logs.
User avatar
nick.bolton
The Big Cheese
Posts: 2250
Joined: Thu Aug 28, 2008 4:02 pm

Re: Torrent busted using 4.16.6

Sat May 08, 2021 11:08 am

No it doesn't.
Also, are you using MalwareBytes?
AussieRodney
Travelling Tuatara
Location: Seattle
Posts: 39
Joined: Tue Nov 29, 2016 2:13 pm

Re: Torrent busted using 4.16.6

Sat May 08, 2021 12:41 pm

I am.
User avatar
nick.bolton
The Big Cheese
Posts: 2250
Joined: Thu Aug 28, 2008 4:02 pm

Re: Torrent busted using 4.16.6

Sat May 08, 2021 1:38 pm

Ok, I thought MalwareBytes had fixed this as we've not had any issues for a long time. Essentially we're using the same 'driver' in both our software, theirs in the 'Web Protection' feature, but they're using an outdated version and it's causing issues with HideAway and lots of other software companies. For HideAway specifically it can cause it to not redirect the connection. So the solution is to disable the Web Protection component in MalWareBytes. It slows down your connection anyway.
You could check to see if you're using the latest version of MalwareBytes too.
AussieRodney
Travelling Tuatara
Location: Seattle
Posts: 39
Joined: Tue Nov 29, 2016 2:13 pm

Re: Torrent busted using 4.16.6

Sat May 08, 2021 2:33 pm

Thanks, Nick. Done, both of those.

I'll see how it pans out.

Return to “HideAway”