Can't launch MWP from system tray

Forum for MailWasher Pro 7 and/or older 2011/2012 versions.
Dimi2018
Rattled Rabbit
Posts: 3
Joined: Thu Jan 10, 2019 11:27 am

Can't launch MWP from system tray

Thu Jan 10, 2019 11:33 am

Hi I have the latest version of MailWasher Pro. While it loads itself into the system tray just fine and does its job, I can't launch it if I double click the icon in the system tray. I have to launch it from the start menu. After I click on the close button on the upper right it goes back to the system tray. But, I still need to launch it from the start menu, regardless. Any solutions? Thanks.
User avatar
rusticdog
Firetrust Monkey
Contact:
Posts: 13843
Joined: Mon Jun 13, 2005 6:27 pm

Re: Can't launch MWP from system tray

Thu Jan 10, 2019 11:54 am

Hi there

If you go into the Task Manager (CTRL + SHIFT + ESC) in the list of processes, MailWasher is just listed once correct ?

If you haven't restarted the machine in a while, try that first.

My next suggestion would be try a .NET Repair, then reboot. You can download the repair utility from
https://www.microsoft.com/en-nz/downloa ... x?id=30135

If still no good, try reinstalling MailWasher https://www.firetrust.com/products/mail ... o/download
No need to uninstall, just select Repair if prompted for that.

A System File Scan would be after that, details here https://support.microsoft.com/en-nz/hel ... ted-system

Thanks
User avatar
Digerati
Microsoft MVP
Location: Nebraska, USA
Posts: 1566
Joined: Thu Jul 24, 2008 3:16 pm

Re: Can't launch MWP from system tray

Fri Jan 11, 2019 4:54 am

My next suggestion would be try a .NET Repair, then reboot.
FYI - Just thought I would mention that Tuesday Microsoft pushed out a Windows Update (KB4480056) that was a "Cumulative Update for .NET Framework 3.5 and 4.7.2".

FTR, MWP on my systems is working fine after that update.
Image Bill (AFE7Ret)
Freedom is NOT Free!
Image Windows and Devices for IT, 2007 - 2018
Heat is the bane of all electronics!
─────────────────────
Dimi2018
Rattled Rabbit
Posts: 3
Joined: Thu Jan 10, 2019 11:27 am

Re: Can't launch MWP from system tray

Fri Jan 11, 2019 1:01 pm

thanks. all fixed.
User avatar
Digerati
Microsoft MVP
Location: Nebraska, USA
Posts: 1566
Joined: Thu Jul 24, 2008 3:16 pm

Re: Can't launch MWP from system tray

Sat Jan 12, 2019 5:38 am

Dimi2018 wrote:thanks. all fixed.
While happy you got it fixed, it should be noted forums like this one are places to learn and to share what we have learned so others might benefit from what we have learned.

Simply saying "all fixed" helps no one else learn from your experiences. So how about sharing what you learned and tell us what fixed your problem?
Image Bill (AFE7Ret)
Freedom is NOT Free!
Image Windows and Devices for IT, 2007 - 2018
Heat is the bane of all electronics!
─────────────────────
User avatar
Digerati
Microsoft MVP
Location: Nebraska, USA
Posts: 1566
Joined: Thu Jul 24, 2008 3:16 pm

Re: Can't launch MWP from system tray

Sat Jan 12, 2019 5:50 am

It should be noted that some don't even say, "all fixed" but instead never reply after they fix their issues.
Very true and that is even more frustrating.

Thanks for coming back and posting your solution.
Image Bill (AFE7Ret)
Freedom is NOT Free!
Image Windows and Devices for IT, 2007 - 2018
Heat is the bane of all electronics!
─────────────────────
Dimi2018
Rattled Rabbit
Posts: 3
Joined: Thu Jan 10, 2019 11:27 am

Re: Can't launch MWP from system tray

Sat Jan 12, 2019 5:51 am

I did everything listed in the exact order--including the Windows update. When I was done, it started working again. It should be noted that some don't even say, "all fixed" but instead never reply after they fix their issues.

Return to “MailWasher Pro 7”