Socket::Resolve() failed with code 11004

Well, it's up and running, but I'm not sure if it's doing what it should.
ssheridan
Rattled Rabbit
Location: Portland, OR
Posts: 3
Joined: Sat Feb 20, 2010 11:54 am

Socket::Resolve() failed with code 11004

Sat Feb 20, 2010 12:11 pm

I checked the log today and I am seeing this failure message posting over and over. I have version 2.74 {W} installed. Here is the full error line:

2010-02-19 14:32:08 [568] Error: FilterManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.

I have restarted the service and everything appears to start up fine, but errors continue to appear. Please let me know if anyone knows the cause and how to resolve it. A portion of the log is included below with details beginning at the service restart today. More logs can be attached by request.
--------------------------------------------------
2010-02-19 14:37:12 [760] Info: Shutdown Auto-reporting....
2010-02-19 14:37:12 [760] Info: Shutdown HouseKeepingTask....
2010-02-19 14:37:12 [760] Info: Shutdown WebManager....
2010-02-19 14:37:13 [760] Info: Shutdown MTA proxy....
2010-02-19 14:37:13 [760] Info: Shutdown FilterManagerThreads....
2010-02-19 14:37:13 [568] Info: FilterManagerThread::ObjectThreadMethod - ending
2010-02-19 14:37:13 [760] Info: Shutdown UploadManagerThread....
2010-02-19 14:37:13 [4268] Info: UploadManagerThread::ObjectThreadMethod - ending
2010-02-19 14:37:13 [760] Info: Shutdown StatThread....
2010-02-19 14:37:13 [760] Info: Close database....
2010-02-19 14:37:13 [760] Info: Ending MWES....
2010-02-19 14:37:14 [4296] Info: starting mwes version 2.7.4 {W}
2010-02-19 14:37:14 [4296] Info: environment....
2010-02-19 14:37:14 [4296] Info: cfs_max_cache_size::20000
2010-02-19 14:37:14 [4296] Info: database_location::C:\Program Files\MailWasher Enterprise Server\data
2010-02-19 14:37:14 [4296] Info: default_page::Quarantined.srv
2010-02-19 14:37:14 [4296] Info: home::C:\Program Files\MailWasher Enterprise Server
2010-02-19 14:37:14 [4296] Info: hostname::localhost
2010-02-19 14:37:14 [4296] Info: listen_port::4044
2010-02-19 14:37:14 [4296] Info: log_level::2
2010-02-19 14:37:14 [4296] Info: logging::C:\Program Files\MailWasher Enterprise Server\logs
2010-02-19 14:37:14 [4296] Info: mta_hostname::
2010-02-19 14:37:14 [4296] Info: mta_port::26
2010-02-19 14:37:14 [4296] Info: mta_relay_hostname::192.168.1.200
2010-02-19 14:37:14 [4296] Info: mta_relay_port::26
2010-02-19 14:37:14 [4296] Info: proxy_hostname::
2010-02-19 14:37:14 [4296] Info: proxy_port::25
2010-02-19 14:37:14 [4296] Info: rbl_max_cache_size::20000
2010-02-19 14:37:14 [4296] Info: root_document::C:\Program Files\MailWasher Enterprise Server\site
2010-02-19 14:37:14 [4296] Info: use_check_domains::1
2010-02-19 14:37:14 [4296] Info: use_mta_proxy::1
2010-02-19 14:37:14 [4296] Info: web_hostname::localhost
2010-02-19 14:37:14 [4296] Info: web_port::4044
2010-02-19 14:37:14 [4296] Info: working_domains::
2010-02-19 14:37:14 [4296] Info: Initialising WebManager....
2010-02-19 14:37:14 [4296] Info: Initialising database....
2010-02-19 14:37:14 [4296] Info: Initialising database configure table....
2010-02-19 14:37:14 [4296] Info: DatabaseManager::UpgradeDatabase - version 19 ok
2010-02-19 14:37:14 [4296] Info: Initialising database configure table....
2010-02-19 14:37:14 [4296] Info: Initialising database white listing table....
2010-02-19 14:37:14 [4296] Info: Initialising database black listing table....
2010-02-19 14:37:14 [4296] Info: Initialising database filter black listing table....
2010-02-19 14:37:14 [4296] Info: Initialising database rbl listing table....
2010-02-19 14:37:14 [4296] Info: Initialising database quarantined table....
2010-02-19 14:37:14 [4296] Info: Initialising database gray listing table....
2010-02-19 14:37:14 [4296] Info: Initialising database white listing ip table....
2010-02-19 14:37:14 [4296] Info: Initialising database black listing ip table....
2010-02-19 14:37:14 [4296] Info: Initialising database user table....
2010-02-19 14:37:14 [4296] Info: Initialising database Gray listing friends table....
2010-02-19 14:37:14 [4296] Info: Initialising database Domain table....
2010-02-19 14:37:14 [4296] Info: Initialising Auto-reporting....
2010-02-19 14:37:14 [4296] Info: Starting StatThread....
2010-02-19 14:37:14 [4296] Info: Starting FilterManagerThreads....
2010-02-19 14:37:14 [4932] Info: Starting TaskThread....
2010-02-19 14:37:14 [4296] Info: Starting UploadManagerThread....
2010-02-19 14:37:14 [4296] Info: Starting MTA proxy....
2010-02-19 14:37:14 [4296] Info: Starting HouseKeepingTask....
2010-02-19 14:38:05 [1764] Error: FilterManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:38:43 [1764] Error: FilterManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:38:47 [4932] Info: Processed = 430 - 1, Emails(ok) = 172 - 0, FA = 31 - 0, RBL = 132 - 0, Black listed = 0 - 0, Custom filter = 0 - 0, FA(IP) = 1 - 0, SPF(Lite) = 0 - 0, Gray listed = 94 - 0, Gray listed(ok) = 36 - 0, Empty Email Body = 0 - 0, Uploaded = 54 - 1,
2010-02-19 14:38:48 [1252] Warning: SMTPChannel::ObjectThreadMethod - SocketException - TCPSocket::CheckSocketStatus - connection error reading from the socket [188.80.10.193]() failed with code 10054: An existing connection was forcibly closed by the remote host.
2010-02-19 14:38:55 [2744] Warning: UploadManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:39:21 [1764] Error: FilterManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:39:59 [1764] Error: FilterManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:39:59 [2744] Warning: UploadManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:40:37 [1764] Error: FilterManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:41:07 [2744] Warning: UploadManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:41:15 [1764] Error: FilterManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:41:53 [1764] Error: FilterManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:41:56 [4932] Info: Processed = 431 - 1, Emails(ok) = 172 - 0, FA = 31 - 0, RBL = 133 - 1, Black listed = 0 - 0, Custom filter = 0 - 0, FA(IP) = 1 - 0, SPF(Lite) = 0 - 0, Gray listed = 94 - 0, Gray listed(ok) = 36 - 0, Empty Email Body = 0 - 0, Uploaded = 54 - 0,
2010-02-19 14:42:15 [2744] Warning: UploadManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:42:23 [1764] Warning: FilterManagerThread::ObjectThreadMethod - email timedout
2010-02-19 14:42:31 [1764] Error: FilterManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:42:46 [4932] Info: Processed = 431 - 0, Emails(ok) = 173 - 1, FA = 31 - 0, RBL = 133 - 0, Black listed = 0 - 0, Custom filter = 0 - 0, FA(IP) = 1 - 0, SPF(Lite) = 0 - 0, Gray listed = 94 - 0, Gray listed(ok) = 36 - 0, Empty Email Body = 0 - 0, Uploaded = 54 - 0,
2010-02-19 14:43:09 [1764] Error: FilterManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:43:23 [2744] Warning: UploadManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:43:47 [1764] Error: FilterManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:44:25 [2744] Warning: UploadManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:44:25 [1764] Error: FilterManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
2010-02-19 14:45:03 [1764] Error: FilterManagerThread::ObjectThreadMethod - SocketException - Socket::Resolve() failed with code 11004: The requested name is valid, but no data of the requested type was found.
User avatar
nick.bolton
The Big Cheese
Posts: 1973
Joined: Thu Aug 28, 2008 4:02 pm

Re: Socket::Resolve() failed with code 11004

Thu Feb 25, 2010 2:07 pm

Sorry for the late reply. I'll get our sys admin to reply on this one, but he'll be back tomorrow.
cliff
Evil Firetrust Employee
Posts: 31
Joined: Tue Jul 28, 2009 3:50 pm

Re: Socket::Resolve() failed with code 11004

Thu Feb 25, 2010 3:12 pm

Hi there.

The error you are recieving is typically associated with the MWES software being unable to resolve a DNS name.

There are 2 domains in particular it needs to resolve:
www.firetrust.com (for version checking)
native.first-alert.net (for first alert services).

Can you please check that these 2 domains are resolvable by the operating system.
An easy way is to ping each address.
You may not get a response, but it will attempt a name resolution before attempting the ICMP ping.
If you are not getting an IP resolved, you will need to check your Dns servers.

Feel free to post any responses for further analysis if you are still having issues.
ssheridan
Rattled Rabbit
Location: Portland, OR
Posts: 3
Joined: Sat Feb 20, 2010 11:54 am

Re: Socket::Resolve() failed with code 11004

Mon Mar 08, 2010 1:51 pm

Thanks for the suggestion. I am still seeing the error in the log and a lot of spam is getting through to the Outlook clients. I am hoping you can offer a suggestion to resolve the error and identify mote SPAM with the filters.

Here is what I have found so far based on your suggestion:

I checked the DNS using PING from the command line on the Windows 2003 Server. I am unable to resolve native.first-alert.net from the server. I am, however, able to resolve www.firetrust.com just fine. The ISP being used for the internet connection on the server is Comcast. I tested a ping to native.first-alert.net from my home computer on Verizon FIOS and it resolved with no issues. I called Comcast to tell them it is not resolving by name and the 1st level tech I spoke to was no help at all and didn't seem to understand the problem and I finally gave up.

I think that I could add the name to the LMHOSTS file so it resolves, but I wonder if it resolves to a static IP. When I did a ping from my home computer today for native.first-alert.net the IP was 209.213.221.161. This a different IP than I got back the other day when I did the ping and called Comcast

Please let me know if you have any suggestions for resolving this issue. Is adding it to the LMHOST file a could solution or do I need to call Comcast again and speak to a different tech.

Thanks!
-Sarah
cliff
Evil Firetrust Employee
Posts: 31
Joined: Tue Jul 28, 2009 3:50 pm

Re: Socket::Resolve() failed with code 11004

Tue Mar 09, 2010 4:10 pm

Hi Sarah,

The native.first-alert.net domain does indeed cover a range of IP addresses for load balancing.

DNS resolution is definitely preferred, as if the gateways do change IP, (as has happened recently), you may not be able to get the First Alert service until the IP's are corrected to match.
However if you are unable to use DNS resolution you can manually set the gateways that it connects to.

As you are using windows you will need to set the following entry in the registry:

Tree: HKEY_LOCAL_MACHINE\Software\Firetrust Limited\mwes (32bit)
Tree: HKEY_LOCAL_MACHINE\Software\wow6432node\Firetrust Limited\mwes (64bit)

Key name: cfs_url
Value: 209.213.221.161;209.213.221.162;209.213.221.163;209.213.221.164;209.213.221.165
Value type: string

Restart MWES via the Windows Services panel

~ C
ssheridan
Rattled Rabbit
Location: Portland, OR
Posts: 3
Joined: Sat Feb 20, 2010 11:54 am

Re: Socket::Resolve() failed with code 11004

Tue Jun 08, 2010 4:59 pm

Cliff,

I just upgraded to the 2.76 and I want to see if it worksif I remove the cfs_url entry I created. I am not sure if it was set to something else previously. Please let me know if I can test this simply by deleting that key.

Thanks,

Sarah
cliff
Evil Firetrust Employee
Posts: 31
Joined: Tue Jul 28, 2009 3:50 pm

Re: Socket::Resolve() failed with code 11004

Wed Jun 09, 2010 10:37 am

Hi again Sarah,

Yes, if you remove the key completely the system will default back to native.first-alert.net and rely on the balancing system.

I would recommend backing up your registry keys (just the MWES tree would be fine) before removing anything - as a precaution.

~ C

Return to “Post Installation”